zoukankan      html  css  js  c++  java
  • poj-1046-color me less

    Description

    A color reduction is a mapping from a set of discrete colors to a smaller one. The solution to this problem requires that you perform just such a mapping in a standard twenty-four bit RGB color space. The input consists of a target set of sixteen RGB color values, and a collection of arbitrary RGB colors to be mapped to their closest color in the target set. For our purposes, an RGB color is defined as an ordered triple (R,G,B) where each value of the triple is an integer from 0 to 255. The distance between two colors is defined as the Euclidean distance between two three-dimensional points. That is, given two colors (R1,G1,B1) and (R2,G2,B2), their distance D is given by the equation

    Input

    The input is a list of RGB colors, one color per line, specified as three integers from 0 to 255 delimited by a single space. The first sixteen colors form the target set of colors to which the remaining colors will be mapped. The input is terminated by a line containing three -1 values.

    Output

    For each color to be mapped, output the color and its nearest color from the target set.

    If there are more than one color with the same smallest distance, please output the color given first in the color set.

    Sample Input

    0 0 0
    255 255 255
    0 0 1
    1 1 1
    128 0 0
    0 128 0
    128 128 0
    0 0 128
    126 168 9
    35 86 34
    133 41 193
    128 0 128
    0 128 128
    128 128 128
    255 0 0
    0 1 0
    0 0 0
    255 255 255
    253 254 255
    77 79 134
    81 218 0
    -1 -1 -1
    题目大意:
    前十六个数据代表已存入map的位置,根据公式求得数据到最近的已存在位置;

    Sample Output

    #include<cmath>
    #include<iostream>
    #include<algorithm>
    using namespace std;
    struct mapa
    {
    
    int a;
    int b;
    int c;
    
    };
    
    int main()
    {  mapa aa[16];
        for(int i=0;i<16;i++)
        {
            cin>>aa[i].a>>aa[i].b>>aa[i].c;
    
        }
         int x,y,z;
        while(cin>>x>>y>>z)
        {
            if(x==-1&&y==-1&&z==-1)break;
            int zh=255*255*3;
            int d,j=0;
            for(int i=0;i<16;i++)
            {
                d=sqrt((aa[i].a-x)*(aa[i].a-x)+(aa[i].b-y)*(aa[i].b-y)+(aa[i].c-z)*(aa[i].c-z));
    
                if(d<zh){zh=d;j=i;}
    
    
            }
            cout<<'('<<x<<','<<y<<','<<z<<')'<<" maps to "<<'('<<aa[j].a<<','<<aa[j].b<<','<<aa[j].c<<')'<<endl;
    
        }
    system("pause");
    
        return 0;
    }
    

      

    (0,0,0) maps to (0,0,0)
    (255,255,255) maps to (255,255,255)
    (253,254,255) maps to (255,255,255)
    (77,79,134) maps to (128,128,128)
    (81,218,0) maps to (126,168,9)
  • 相关阅读:
    剑指offer-二维数组中的查找
    TF-IDF(term frequency–inverse document frequency)
    Java实现中文字符串的排序功能
    当前课程
    【R】资源整理
    CentOS相关
    【转】Setting up SDL Extension Libraries on MinGW
    【转】Setting up SDL Extension Libraries on Visual Studio 2010 Ultimate
    【转】Setting up SDL Extension Libraries on Code::Blocks 12.11
    【转】Setting up SDL Extension Libraries on Visual Studio 2019 Community
  • 原文地址:https://www.cnblogs.com/jin-nuo/p/5298974.html
Copyright © 2011-2022 走看看