zoukankan      html  css  js  c++  java
  • Fishing Master (思维+贪心)

    题目网站:
    http://acm.hdu.edu.cn/showproblem.php?pid=6709


    Problem Description


    Heard that eom is a fishing MASTER, you want to acknowledge him as your mentor. As everybody knows, if you want to be a MASTER’s apprentice, you should pass the trial. So when you find fishing MASTER eom, the trial is as follow:
    There are n fish in the pool. For the i - th fish, it takes at least ti minutes to stew(overcook is acceptable). To simplify this problem, the time spent catching a fish is k minutes. You can catch fish one at a time and because there is only one pot, only one fish can be stewed in the pot at a time. While you are catching a fish, you can not put a raw fish you have caught into the pot, that means if you begin to catch a fish, you can’t stop until after k minutes; when you are not catching fish, you can take a cooked fish (stewed for no less than ti) out of the pot or put a raw fish into the pot, these two operations take no time. Note that if the fish stewed in the pot is not stewed for enough time, you cannot take it out, but you can go to catch another fish or just wait for a while doing nothing until it is sufficiently stewed.
    Now eom wants you to catch and stew all the fish as soon as possible (you definitely know that a fish can be eaten only after sufficiently stewed), so that he can have a satisfying meal. If you can complete that in the shortest possible time, eom will accept you as his apprentice and say “I am done! I am full!”. If you can’t, eom will not accept you and say “You are done! You are fool!”.
    So what’s the shortest time to pass the trial if you arrange the time optimally?


    Input


    The first line of input consists of a single integer
    T(1≤T≤20), denoting the number of test cases.
    For each test case, the first line contains two integers n(1≤n≤1e5),k(1≤k≤1e9)
    , denoting the number of fish in the pool and the time needed to catch a fish.
    the second line contains n integers, t1 , t2 , … ,tn (1≤ti≤109),denoting the least time needed to cook the i-th fish.


    Output


    For each test case, print a single integer in one line, denoting the shortest time to pass the trial.
    Sample Input
    2
    3 5
    5 5 8
    2 4
    3 3
    Sample Output
    23
    11


    Hint


    Case 1: Catch the 3rd fish (5 mins), put the 3rd fish in, catch the 1st fish (5 mins), wait (3 mins),
    take the 3rd fish out, put the 1st fish in, catch the 2nd fish(5 mins),
    take the 1st fish out, put the 2nd fish in, wait (5 mins), take the 2nd fish out.
    Case 2: Catch the 1st fish (4 mins), put the 1st fish in, catch the 2nd fish (4 mins),
    take the 1st fish out, put the 2nd fish in, wait (3 mins), take the 2nd fish out.


    题目大意就是有n条鱼要捉来煮,每次捉鱼都需要k分钟,但每条鱼要煮t分钟,求出最快煮完所有鱼的时间。
    这道题一开始直接让我跟队友自闭,一开始的思路是把煮时间长的鱼先钓上来,而且!一开始找出的样例都证明可行并且敲了出来,然后wa(-5)。后来出了个反例推翻了。在最后8分钟想出了ac思路,就是把每条鱼要煮的时间,如果大于k,就再煮的时候捉t[i]/k条鱼,剩下的时间再就到数组。这样我们就可以得出一个时间全小于k的数组(如果鱼还没有钓完,而如果鱼已经掉完,接下来安心煮鱼就好)。此时无论有多少条鱼没钓没煮,都必须在每条鱼煮的时候钓一条鱼,直到所有鱼钓完。所以此时把得到的数组从大到小排序,有多少条鱼没钓,sum就加多少个k,再加上剩下的鱼要煮的时间,即可得出答案。


    代码


    #include <bits/stdc++.h>
    using namespace std;
    typedef long long ll;
    ll sum ;
    int num , t , n , k , a[100005] ;
    int cmp(int a,int b){return a>b;}
    int main () {
     ios::sync_with_stdio(false);
     cin >> t ;
     while (t--){
      cin >> n >> k ;
      num = 1 ;  //先捉一条鱼上来煮
      sum = k ;  //第一条鱼的时间
      for (int i = 1 ; i <= n ;  i++){
       cin>>a[i];
       if (num < n){
        int x = a[i] / k ; //当前煮鱼时间最多可以完整得捉多少鱼
        if (num + x >= n){
         a[i] = a[i] - (n - num) * k ;
         sum = sum + (n - num) * k ;
         num = n ;
        }else{
         sum = sum + x * k ;
         a[i] = a[i] % k ;
         num = num + x ;
        }
       }
      }
      sort(a+1,a+1+n,cmp);  //此时数组里的数都是小于K的,所以先算捉鱼时间,捉完鱼但没煮的就安心煮鱼好了
      for(int i = 1 ; i <= n ; i++){
       if(num<n){
        sum = sum + k ;
        num++;
       }else{
        sum = sum + a[i];
       }
      }
      cout<<sum<<endl;
     }
     return 0;
    }

  • 相关阅读:
    Ajax的工作原理
    ios 应用多语言自由切换实现
    开源码应用之Eclipse篇
    搜索引擎solr和elasticsearch
    字符串截取进阶
    nginx源代码分析--nginx模块解析
    C#网络编程系列文章(五)之Socket实现异步UDPserver
    mysql存储引擎的种类与差别(innodb与myisam)
    程序的记事本--log4net
    在海思hisiv100nptl平台上交叉编译并安装SRS
  • 原文地址:https://www.cnblogs.com/jjmmboom/p/11470233.html
Copyright © 2011-2022 走看看