zoukankan      html  css  js  c++  java
  • C

    Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers. 

    One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table. 

    For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least. 

    InputThe input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases. 
    OutputFor each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks. 
    Sample Input

    2
    5 3
    1 2
    2 3
    4 5
    
    5 1
    2 5

    Sample Output

    2
    4

    这个题做麻烦了,其实可以直接遍历pre数组,其中pre[i]==i的个数就是所有集合的个数!
    #include<iostream>
    #include<string>
    #include<algorithm>
    #include<cstdio>
    #include<queue>
    #include<cstring>
    #include<cmath>
    #include<vector>
    #include<set>
    #include<iomanip>
    #include<iostream>
    using namespace std;
    #define MAXN 30000 
    #define INF 0x3f3f3f3f
    /*
    并查集
    */
    set<int> s;
    int pre[MAXN],n,m;
    int find(int x)
    {
        if(x==pre[x])
            return x;
        else
            return pre[x] = find(pre[x]);
    }
    void mix(int x,int y)
    {
        int fx = find(x),fy = find(y);
        if(fx!=fy)
            pre[fy] = fx;
    }
    int main()
    {
        int t;
        cin>>t;
        while(t--)
        {
            int x,y;
            cin>>n>>m;
            for(int i=0;i<=n;i++)
                pre[i] = i;
            s.clear();
            for(int i=0;i<m;i++)
            {
                cin>>x>>y;
                mix(x,y);
            }
            int cnt = 0;
            for(int i=1;i<=n;i++)
            {
                int fi = find(i);
                if(!s.count(fi))
                {
                    cnt++;
                    s.insert(fi);
                }
            }
            cout<<cnt<<endl;
        }
        return 0;
    }
  • 相关阅读:
    bzoj 1977
    bzoj 3389
    bzoj 1064
    codeforces 424D
    codeforces 425C
    codeforces 425D
    codeforces 427E
    codeforces 425E
    codeforces 429D
    codeforces 429E
  • 原文地址:https://www.cnblogs.com/joeylee97/p/6595919.html
Copyright © 2011-2022 走看看