zoukankan      html  css  js  c++  java
  • POJ 3169(差分约束+SPFA)

    Layout
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 17569   Accepted: 8450

    Description

    Like everyone else, cows like to stand close to their friends when queuing for feed. FJ has N (2 <= N <= 1,000) cows numbered 1..N standing along a straight line waiting for feed. The cows are standing in the same order as they are numbered, and since they can be rather pushy, it is possible that two or more cows can line up at exactly the same location (that is, if we think of each cow as being located at some coordinate on a number line, then it is possible for two or more cows to share the same coordinate). 

    Some cows like each other and want to be within a certain distance of each other in line. Some really dislike each other and want to be separated by at least a certain distance. A list of ML (1 <= ML <= 10,000) constraints describes which cows like each other and the maximum distance by which they may be separated; a subsequent list of MD constraints (1 <= MD <= 10,000) tells which cows dislike each other and the minimum distance by which they must be separated. 

    Your job is to compute, if possible, the maximum possible distance between cow 1 and cow N that satisfies the distance constraints.

    Input

    Line 1: Three space-separated integers: N, ML, and MD. 

    Lines 2..ML+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at most D (1 <= D <= 1,000,000) apart. 

    Lines ML+2..ML+MD+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at least D (1 <= D <= 1,000,000) apart.

    Output

    Line 1: A single integer. If no line-up is possible, output -1. If cows 1 and N can be arbitrarily far apart, output -2. Otherwise output the greatest possible distance between cows 1 and N.

    Sample Input

    4 2 1
    1 3 10
    2 4 20
    2 3 3

    Sample Output

    27

    Hint

    Explanation of the sample: 

    There are 4 cows. Cows #1 and #3 must be no more than 10 units apart, cows #2 and #4 must be no more than 20 units apart, and cows #2 and #3 dislike each other and must be no fewer than 3 units apart. 

    The best layout, in terms of coordinates on a number line, is to put cow #1 at 0, cow #2 at 7, cow #3 at 10, and cow #4 at 27.
     
    题意:n头牛,ml个关系,md个关系。接下来ml+md行是ABC:ml是代表A和B的距离小于C,md代表A和B的距离大于C
    A和B的距离小于C侧建一条A到B,权值为C的路。A和B的距离大于C侧建一条B到A权值为C的路
    SPFA跑最短路OK
    #include <iostream>
    #include <cmath>
    #include <cstdio>
    #include <cstring>
    #include <string>
    #include <map>
    #include <iomanip>
    #include <algorithm>
    #include <queue>
    #include <stack>
    #include <set>
    #include <vector>
    //const int maxn = 1e5+5;
    #define ll long long
    ll gcd(ll a,ll b){return b?gcd(b,a%b):a;}
    ll lcm(ll a,ll b){return a/gcd(a,b)*b;}
    #define inf 0x3f3f3f3f
    #define MAX INT_MAX
    #define FOR(i,a,b) for( int i = a;i <= b;++i)
    #define bug cout<<"--------------"<<endl
    using namespace std;
    
    int n,m,tot,A,B;
    int ver[21000],edge[21000],nextt[21000],head[21000],vis[21000],d[21000],ans[21000];
    
    void add(int x,int y,int z)
    {
        ver[++tot] = y,edge[tot] = z,nextt[tot] = head[x],head[x] = tot;
    }
    int SPFA()
    {
    
        queue<int>que;
        memset(vis,0,sizeof(vis));
        memset(d,inf,sizeof(d));
        memset(ans,0,sizeof(ans));
        d[1] = 0;
        vis[1] = 1;
        ans[1] ++;
        que.push(1);
        while(que.size())
        {
            int x = que.front();que.pop();
            //cout<<x<<" "<<ans[x]<<endl;
            vis[x] = 0 ;
            for(int i= head[x];i;i=nextt[i])
            {
                int y = ver[i],z = edge[i];
                if( d[y] > d[x] + z )
                {
                    d[y] = d[x] + z;
                    if(vis[y] == 1) continue;
                    vis[y] = 1;
                    que.push(y);
                    if(++ans[y] >= n ) return 0;
                }
            }
        }
        return 1;
    }
    int main()
    {
    
          ios::sync_with_stdio(false);
          int ml,md;
        cin>>n>>ml>>md;
        FOR(i,1,ml)
        {
            int x,y,z;
            cin>>x>>y>>z;
            add(x,y,z);
        }
        FOR(i,1,md)
        {
            int x,y,z;
            cin>>x>>y>>z;
            add(y,x,-z);
        }
        if(SPFA() == 0) cout<<"-1"<<endl;
        else if(d[n] == inf) cout<<"-2"<<endl;
        else cout<<d[n]<<endl;
    
    
    
    
    }
  • 相关阅读:
    luogu P1877 [HAOI2012]音量调节
    luogu P1510 精卫填海
    luogu P1508 Likecloud-吃、吃、吃
    我的VIM
    luogu P1310 表达式的值
    luogu P1402 酒店之王
    luogu P3119 [USACO15JAN]草鉴定Grass Cownoisseur
    luogu P1879 [USACO06NOV]玉米田Corn Fields
    luogu P2746 [USACO5.3]校园网Network of Schools
    [BZOJ4870][六省联考2017]组合数问题(组合数动规)
  • 原文地址:https://www.cnblogs.com/jrfr/p/11371125.html
Copyright © 2011-2022 走看看