zoukankan      html  css  js  c++  java
  • POJ 1733(边带权并查集+离散化)

    Parity game
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 15492   Accepted: 5876

    Description

    Now and then you play the following game with your friend. Your friend writes down a sequence consisting of zeroes and ones. You choose a continuous subsequence (for example the subsequence from the third to the fifth digit inclusively) and ask him, whether this subsequence contains even or odd number of ones. Your friend answers your question and you can ask him about another subsequence and so on. Your task is to guess the entire sequence of numbers. 

    You suspect some of your friend's answers may not be correct and you want to convict him of falsehood. Thus you have decided to write a program to help you in this matter. The program will receive a series of your questions together with the answers you have received from your friend. The aim of this program is to find the first answer which is provably wrong, i.e. that there exists a sequence satisfying answers to all the previous questions, but no such sequence satisfies this answer.

    Input

    The first line of input contains one number, which is the length of the sequence of zeroes and ones. This length is less or equal to 1000000000. In the second line, there is one positive integer which is the number of questions asked and answers to them. The number of questions and answers is less or equal to 5000. The remaining lines specify questions and answers. Each line contains one question and the answer to this question: two integers (the position of the first and last digit in the chosen subsequence) and one word which is either `even' or `odd' (the answer, i.e. the parity of the number of ones in the chosen subsequence, where `even' means an even number of ones and `odd' means an odd number).

    Output

    There is only one line in output containing one integer X. Number X says that there exists a sequence of zeroes and ones satisfying first X parity conditions, but there exists none satisfying X+1 conditions. If there exists a sequence of zeroes and ones satisfying all the given conditions, then number X should be the number of all the questions asked.

    Sample Input

    10
    5
    1 2 even
    3 4 odd
    5 6 even
    1 6 even
    7 10 odd

    Sample Output

    3
    题目:一个长度为n且只由0和1组成的序列。由m个询问,下面m行两个数l,r,和even或者odd表示闭区间l到r有奇数个还是偶数个1.求的一个最小的k,使得这个01序满足在1到k个问题,而不满足1到k+1个问题
    思路:n很大,m小,先离散化处理,再用带权并查集
    #include <iostream>
    #include <cmath>
    #include <cstdio>
    #include <cstring>
    #include <string>
    #include <map>
    #include <iomanip>
    #include <algorithm>
    #include <queue>
    #include <stack>
    #include <set>
    #include <vector>
    //const int maxn = 1e5+5;
    #define ll long long
    ll gcd(ll a,ll b){return b?gcd(b,a%b):a;}
    ll lcm(ll a,ll b){return a/gcd(a,b)*b;}
    
    #define MAX INT_MAX
    #define FOR(i,a,b) for( int i = a;i <= b;++i)
    #define bug cout<<"--------------"<<endl
    using namespace std;
    int n,m,t;
    struct node
    {
        int l,r;
        int ans; // ans表示第i次询问是奇还是偶
    }query[20010];
    int tot;
    //fa表示并查集- -,d【i】表示x与fa【i】的奇偶性关系
    int a[20010],fa[20010],d[20010];
    void cinin() //离散化代码
    {
        scanf("%d %d",&n,&m);
    
        FOR(i,1,m)
        {
            char c[20];
            scanf("%d %d %s",&query[i].l,&query[i].r,c);
            a[++tot] = query[i].l;
            a[++tot] = query[i].r;
            if(c[0] == 'o') query[i].ans = 1;
            else query[i].ans = 0;
        }
        sort(a+1,a+1+tot);
        tot = unique(a+1,a+1+tot) - a - 1;
    }
    int get(int x)
    {
        if(x == fa[x]) return fa[x];
        int root = get(fa[x]);
        d[x] ^= d[fa[x]];
        return fa[x] = root;
    }
    int main()
    {
    
        cinin();
        for(int i=1;i<=tot;i++) fa[i] = i;//注意这里是tot不是n
        for(int i =1;i<=m;i++)
        {
            int x = lower_bound(a+1,a+1+tot,query[i].l-1) - a;//注意区间是0到l-1和区间0到r,左闭右开
            int y = lower_bound(a+1,a+1+tot,query[i].r) - a;
            int fx = get(x) , fy = get(y);
            if(fx == fy)
            {
                if((d[x] ^ d[y]) != query[i].ans)
                {
                    cout<<i-1<<endl;
                    return 0;
                }
            }
            else
            {
                fa[fx] = fy;
                //a = b ^ c ^ d 等价于 b = a ^ c ^ d 
                d[fx] = d[x] ^ d[y] ^ query[i].ans;
            }
        }
        cout<<m<<endl;
    
    
    
    }

  • 相关阅读:
    Mac小知识点
    UIScrollView直接在StoryBoard中拖控件
    iOS小工具
    iOS设备信息
    Android Studio stuck on “Gradle: resolve dependancies '_debugCompile'” or 'detachedConfiguration1'
    iOS开发插件集
    Include guards
    oc单例
    Java反射中与自动装箱有关的坑及其解决方案
    ByxAOP——简易AOP框架
  • 原文地址:https://www.cnblogs.com/jrfr/p/11403908.html
Copyright © 2011-2022 走看看