zoukankan      html  css  js  c++  java
  • Parencodings 分类: POJ 2015-06-28 22:00 7人阅读 评论(0) 收藏

    Parencodings
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 22757   Accepted: 13337

    Description

    Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two different ways:
    q By an integer sequence P = p1 p2...pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence).
    q By an integer sequence W = w1 w2...wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence).

    Following is an example of the above encodings:
    	S		(((()()())))
    
    	P-sequence	    4 5 6666
    
    	W-sequence	    1 1 1456
    
    

    Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string.

    Input

    The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.

    Output

    The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.

    Sample Input

    2
    6
    4 5 6 6 6 6
    9 
    4 6 6 6 6 8 9 9 9
    

    Sample Output

    1 1 1 4 5 6
    1 1 2 4 5 1 1 3 9
    
    #include <iostream>
    #include <cstring>
    #include <cstdio>
    #include <cmath>
    #include <string>
    #include <stack>
    #include <algorithm>
    using namespace std;
    
    const int Max=1100000;
    
    int Arr[110];
    bool vis[1100];
    int main()
    {
        int T;
        int n;
        while(~scanf("%d",&T))
        {
            while(T--)
            {
                scanf("%d",&n);
                int Max=0;
                int sum;
                for(int i=0;i<n;i++)
                {
                    scanf("%d",&Arr[i]);
                    if(Arr[i]>Max)
                    {
                        Max=Arr[i];
                    }
                }
                Max+=n;
                sum=Max;
                memset(vis,false,sizeof(vis));
                vis[Max]=true;
                for(int i=n-2;i>=0;i--)
                {
    
                    Max-=(Arr[i+1]-Arr[i]+1);
                    vis[Max]=true;
                }
                int top=0;
                for(int i=1;i<=sum;i++)
                {
                    if(vis[i])
                    {
                        int ans=0;
                        int ant=0;
                        for(int j=i;j>=1;j--)
                        {
                            if(vis[j])
                            {
                                ans++;
                            }
                            else
                            {
                                ans--;
                                ant++;
                            }
                            if(!ans)
                            {
                                break;
                            }
                        }
                        Arr[top++]=ant;
                    }
                }
                for(int i=0;i<n;i++)
                {
                    if(i)
                        cout<<" ";
                    cout<<Arr[i];
                }
                cout<<endl;
            }
        }
        return 0;
    }
    


    版权声明:本文为博主原创文章,未经博主允许不得转载。

  • 相关阅读:
    SAP PI 如何实现消息定义查询
    EWM与ERP交互程序
    ITS Mobile Template interpretation failed. Template does not exist
    SAP Material Flow System (MFS) 物料流系统简介
    SAP EWM Table list
    EWM RF 屏幕增强
    SAP EWM TCODE list
    SAP扩展仓库管理(SAPEWM)在线研讨会笔记
    ERP与EWM集成配置ERP端组织架构(二)
    EWM RF(Radio Frequency)简介
  • 原文地址:https://www.cnblogs.com/juechen/p/4721972.html
Copyright © 2011-2022 走看看