zoukankan      html  css  js  c++  java
  • Uniform Generator 分类: HDU 2015-06-19 23:26 11人阅读 评论(0) 收藏

    Uniform Generator
    Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 21176 Accepted Submission(s): 8294

    Problem Description
    Computer simulations often require random numbers. One way to generate pseudo-random numbers is via a function of the form

    seed(x+1) = [seed(x) + STEP] % MOD

    where ‘%’ is the modulus operator.

    Such a function will generate pseudo-random numbers (seed) between 0 and MOD-1. One problem with functions of this form is that they will always generate the same pattern over and over. In order to minimize this effect, selecting the STEP and MOD values carefully can result in a uniform distribution of all values between (and including) 0 and MOD-1.

    For example, if STEP = 3 and MOD = 5, the function will generate the series of pseudo-random numbers 0, 3, 1, 4, 2 in a repeating cycle. In this example, all of the numbers between and including 0 and MOD-1 will be generated every MOD iterations of the function. Note that by the nature of the function to generate the same seed(x+1) every time seed(x) occurs means that if a function will generate all the numbers between 0 and MOD-1, it will generate pseudo-random numbers uniformly with every MOD iterations.

    If STEP = 15 and MOD = 20, the function generates the series 0, 15, 10, 5 (or any other repeating series if the initial seed is other than 0). This is a poor selection of STEP and MOD because no initial seed will generate all of the numbers from 0 and MOD-1.

    Your program will determine if choices of STEP and MOD will generate a uniform distribution of pseudo-random numbers.

    Input
    Each line of input will contain a pair of integers for STEP and MOD in that order (1 <= STEP, MOD <= 100000).

    Output
    For each line of input, your program should print the STEP value right- justified in columns 1 through 10, the MOD value right-justified in columns 11 through 20 and either “Good Choice” or “Bad Choice” left-justified starting in column 25. The “Good Choice” message should be printed when the selection of STEP and MOD will generate all the numbers between and including 0 and MOD-1 when MOD numbers are generated. Otherwise, your program should print the message “Bad Choice”. After each output test set, your program should print exactly one blank line.

    Sample Input

    3 5 15 20 63923 99999

    Sample Output

    3 5 Good Choice 15 20 Bad Choice 63923 99999 Good Choice
    小小的空格PE好几次,基础不扎实啊

    #include <iostream>
    #include <iomanip>
    #include <cstdio>
    #include <cstring>
    using namespace std;
    const int Max=110000;
    bool vis[Max];
    int main()
    {
       int STEP,MOD;
       while(cin>>STEP>>MOD)
       {
           memset(vis,false,sizeof(vis));
           vis[0]=true;
           int sum=0;
           int ans=1;
           while(1)
           {
               sum=(sum+STEP)%MOD;
               if(vis[sum])
               {
                   break;
               }
               else
               {
                   vis[sum]=true;
                   ans++;
               }
           }
           if(ans<MOD)
           {
               printf("%10d%10d    Bad Choice
    
    ",STEP,MOD);
           }
           else
           {
               printf("%10d%10d    Good Choice
    
    ",STEP,MOD);
           }
       }
        return 0;
    }
    

    版权声明:本文为博主原创文章,未经博主允许不得转载。

  • 相关阅读:
    360天擎安装上之后,手机开热点之后就没有办法连接
    Redis基本数据类型--Hash(哈希)
    Redis基本数据类型--Set
    redis的五种基本数据类型之List
    Redis的五种基本数据类型 String
    Android应用程序的安装位置
    Java中long和Long有什么区别(转)
    Logcat打印调试信息
    Java GUI图形界面开发工具
    CSDN精选Android开发博客
  • 原文地址:https://www.cnblogs.com/juechen/p/4722004.html
Copyright © 2011-2022 走看看