zoukankan      html  css  js  c++  java
  • Boring count(字符串处理)

    Boring count
    Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 787 Accepted Submission(s): 325

    Problem Description
    You are given a string S consisting of lowercase letters, and your task is counting the number of substring that the number of each lowercase letter in the substring is no more than K.

    Input
    In the first line there is an integer T , indicates the number of test cases.
    For each case, the first line contains a string which only consist of lowercase letters. The second line contains an integer K.
    [Technical Specification]
    1<=T<= 100
    1 <= the length of S <= 100000
    1 <= K <= 100000
    Output
    For each case, output a line contains the answer.
    Sample Input
    3
    abc
    1
    abcabc
    1
    abcabc
    2
    Sample Output
    6
    15
    21
    官方题解:
    1003 Boring count
    枚举字符串下标i,每次计算以i为结尾的符合条件的最长串。那么以i为结尾的符合条件子串个数就是最长串的长度。求和即可。
    计算以i为结尾的符合条件的最长串两种方法:
    1.维护一个起点下标startPos,初始为1。如果当前为i,那么cnt[str[i]]++,如果大于k的话,就while( str[startPos] != str[i+1] ) cnt[str[startPos]]–, startPos++; 每次都保证 startPos~i区间每个字母个数都不超过k个。ans += ( i-startPos+1 )。 时间复杂度O(n)
    自己当时怎么没有想到呢?

    #include <set>
    #include <map>
    #include <list>
    #include <stack>
    #include <cmath>
    #include <queue>
    #include <string>
    #include <cstdio>
    #include <cstdlib>
    #include <cstring>
    #include <iostream>
    #include <algorithm>
    #define PI cos(-1.0)
    #define RR freopen("input.txt","r",stdin)
    using namespace std;
    typedef long long LL;
    const int Max= 100010;
    char str[Max];
    int vis[30];
    int main()
    {
        int k;
        int T;
        int len;
        LL sum;
        scanf("%d",&T);
        while(T--)
        {
            scanf("%s",str);
            scanf("%d",&k);
            memset(vis,0,sizeof(vis));
            len = strlen(str);
            int ans=0;
            sum=0;
            for(int i=0;i<len;i++)
            {
                vis[str[i]-'a']++;
                while(vis[str[i]-'a']>k)
                {
                    vis[str[ans]-'a']--;
                    ans++;
                }
                sum+=(i-ans+1);
    
            }
           cout<<sum<<endl;
        }
        return 0;
    }
    
  • 相关阅读:
    【转】linux tail命令使用方法详解
    机器学习:利用卷积神经网络实现图像风格迁移 (二)
    狄拉克函数(Dirac delta function)
    狄拉克函数(Dirac delta function)
    写作的积累 —— 台词
    写作的积累 —— 台词
    exponential family distribution(指数族分布)
    exponential family distribution(指数族分布)
    机器学习:利用卷积神经网络实现图像风格迁移 (一)
    十万个为什么 —— 古代没有拼音,怎么认字?
  • 原文地址:https://www.cnblogs.com/juechen/p/5255955.html
Copyright © 2011-2022 走看看