zoukankan      html  css  js  c++  java
  • HDU 1242 Rescue (BFS(广度优先搜索))

    Rescue

    Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 12441 Accepted Submission(s): 4551


    Problem Description
    Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

    Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

    You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)
     
    Input
    First line contains two integers stand for N and M.

    Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend.

    Process to the end of the file.
     
    Output
    For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life."
     
    Sample Input
    7 8 #.#####. #.a#..r. #..#x... ..#..#.# #...##.. .#...... ........
     
    Sample Output
    13
     



    思路:BFS(广度优先搜索)


    import java.io.*;
    import java.util.*;
    public class Main {
    	Queue<Node> que=new LinkedList<Node>();
    	int n,m,sx,sy;
    	char ch[][];
    	int fx[]={1,-1,0,0};
    	int fy[]={0,0,1,-1};
    	boolean boo[][]=new boolean[202][202];
    	public static void main(String[] args) {
    		new Main().work();
    
    	}
    	void work(){
        	Scanner sc=new Scanner(new BufferedInputStream(System.in));
        	while(sc.hasNext()){
        		que.clear();
        		n=sc.nextInt();
        		m=sc.nextInt();
        		ch=new char[n][m];
        		for(int i=0;i<n;i++){
        			String s=sc.next();
        			ch[i]=s.toCharArray();
        			Arrays.fill(boo[i],false);
        		}
        		Node bode=new Node();
        		for(int i=0;i<n;i++){
        			for(int j=0;j<m;j++){
        				if(ch[i][j]=='a'){
        					bode.x=i;
        					bode.y=j;
        				}
        			}
        		}
        		boo[bode.x][bode.y]=true;
        		bode.t=0;
        		que.add(bode);
        		BFS();
        	}
        }
    	void BFS(){
        	while(!que.isEmpty()){
        		Node bode=que.poll();
        		if(ch[bode.x][bode.y]=='r'){
        			System.out.println(bode.t);
        			return;
        		}
        		for(int i=0;i<4;i++){
        			int px=bode.x+fx[i];
    				int py=bode.y+fy[i];
        			if(check(px,py)&&!boo[px][py]){
        				Node t1=new Node();
        				if(ch[px][py]=='x'){
        					t1.t=bode.t+2;
        				}
        				else{
        					t1.t=bode.t+1;
        				}
        				t1.x=px;
        				t1.y=py;
        				boo[px][py]=true;
        				que.add(t1);
        			}
        		}
        	}
        	System.out.println("Poor ANGEL has to stay in the prison all his life.");
        }
    	boolean check(int px,int py){
    		if(px<0|px>n-1||py<0||py>m-1||ch[px][py]=='#')
    			return false;
    		return true;
    	}
    	class Node{
    		int x;
    		int y;
    		int t; 
    	}
    }
    



  • 相关阅读:
    sqlserver 跟踪标志
    解决ORA-00338,ORA-00312
    oracle SQL性能分析
    高潜力人士和员工
    pymysqlreplication
    Python3操作Excel(写入)
    CentOS7.4 源码安装MySQL8.0
    MySql 时间操作实例
    python+eclipse+pydev开发环境搭建
    MySQL表结构同步工具 mysql-schema-sync
  • 原文地址:https://www.cnblogs.com/keanuyaoo/p/3262928.html
Copyright © 2011-2022 走看看