zoukankan      html  css  js  c++  java
  • 每天一道算法_6_I Think I Need a Houseboat

    今天的题目是I Think I Need a Houseboat

    如下:

    Description

    Fred Mapper is considering purchasing some land in Louisiana to build his house on. In the process of investigating the land, he learned that the state of Louisiana is actually shrinking by 50 square miles each year, due to erosion caused by the Mississippi River. Since Fred is hoping to live in this house the rest of his life, he needs to know if his land is going to be lost to erosion.  

    After doing more research, Fred has learned that the land that is being lost forms a semicircle. This semicircle is part of a circle centered at (0,0), with the line that bisects the circle being the X axis. Locations below the X axis are in the water. The semicircle has an area of 0 at the beginning of year 1. (Semicircle illustrated in the Figure.)  

    Input

    The first line of input will be a positive integer indicating how many data sets will be included (N). Each of the next N lines will contain the X and Y Cartesian coordinates of the land Fred is considering. These will be floating point numbers measured in miles. The Y coordinate will be non-negative. (0,0) will not be given.

    Output

    For each data set, a single line of output should appear. This line should take the form of: “Property N: This property will begin eroding in year Z.” Where N is the data set (counting from 1), and Z is the first year (start from 1) this property will be within the semicircle AT THE END OF YEAR Z. Z must be an integer. After the last data set, this should print out “END OF OUTPUT.”

    Sample Input

    2
    1.0 1.0
    25.0 0.0
    
    

    Sample Output

    Property 1: This property will begin eroding in year 1.
    Property 2: This property will begin eroding in year 20.
    END OF OUTPUT.
    

    Hint

    1.No property will appear exactly on the semicircle boundary: it will either be inside or outside.  
    2.This problem will be judged automatically. Your answer must match exactly, including the capitalization, punctuation, and white-space. This includes the periods at the ends of the lines.  
    3.All locations are given in miles.

    代码如下:

    import java.util.ArrayList;
    import java.util.List;
    import java.util.Scanner;
    
    
    public class IThinkINeedaHouseboat {
    	public static void main(String args[]){
    		double PI = 3.1415926;
    		int year = 1;
    		float area = 0;
    		int year_count = 0;
    		Scanner in = new Scanner(System.in);
    		int all = in.nextInt();
    		int count = all * 2;
    		List<Float> list = new ArrayList<Float>();
    		while(count > 0){
    			count--;
    			list.add(in.nextFloat());
    		}
    		for(int i = 0; i<list.size(); i = i + 2){
    			year_count ++;
    			area = (float) (PI*(list.get(i) * list.get(i) + list.get(i + 1) * list.get(i + 1))/2);
    			for(year = 1; year * 50 < area; year ++){
    				
    			}
    			System.out.println("Property "+ year_count + ": This property will begin eroding in year " + year + ".");
    		}
    		System.out.println("END OF OUTPUT.");
    	}
    }
    


     

    作者:jason0539

    微博:http://weibo.com/2553717707

    博客:http://blog.csdn.net/jason0539(转载请说明出处)

  • 相关阅读:
    JavaWeb--JDBC
    JavaWeb--过滤器、监听器
    Javaweb-MVC三层架构
    JavaWeb--JSP
    JavaWeb--Cookie、Session
    JavaWeb--Servlet
    实用记录文档
    分库分表Sharding-JDBC + MyBatis-Plus动态表名
    如何不靠运气变得富有 (九) —— 互联网极大地丰富了职业发展的可能性
    如何不靠运气变得富有 (八) —— 给社会提供它不知道如何获得的东西
  • 原文地址:https://www.cnblogs.com/keanuyaoo/p/3359732.html
Copyright © 2011-2022 走看看