zoukankan      html  css  js  c++  java
  • How Many Tables

    描述

    Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

    One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

    For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

    输入

    The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

    输出

    For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

    样例输入

     

    2
    5 3
    1 2
    2 3
    4 5

    5 1
    2 5

    样例输出

     

    2
    4


    一个并查集入门题

     

    #include<iostream>
    #include<cstdio>
    using namespace std;
    int a[10000];
    int find(int x)
    {
        if(x==a[x])return x;
        return a[x]=find(a[x]);
    }
    int main()
    {
        int cc;
        scanf("%d",&cc);
        while(cc--)
        {
            int n,m,c,d;
            scanf("%d %d",&n,&m);
            for(int i=1;i<=n;i++)
                a[i]=i;
            for(int i=1;i<=m;i++)
            {
                scanf("%d %d",&c,&d);
                int p=find(c);
                int q=find(d);
                if(p!=q)
                    {a[p]=q;n--;}
            }
            cout<<n<<endl;
        }
        return 0;
    }
    



  • 相关阅读:
    java8 list 删除元素 简单版
    java8 list 删除元素 结构复杂版
    xshell 连接 centos 中的 vi 配色
    Redis 运行出错
    电脑清理秘籍 [ 精心总结 ]
    团队项目之后的反思
    团队项目心得 [ 感想 ]
    团队项目心得 [ 第二阶段项目总结 ]
    团队项目心得 [ 第一阶段项目总结 ]
    《创新者》读书笔记
  • 原文地址:https://www.cnblogs.com/keanuyaoo/p/3397961.html
Copyright © 2011-2022 走看看