zoukankan      html  css  js  c++  java
  • MPI Maelstrom

    MPI Maelstrom
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 2702   Accepted: 1608

    Description

    BIT has recently taken delivery of their new supercomputer, a 32 processor Apollo Odyssey distributed shared memory machine with a hierarchical communication subsystem. Valentine McKee's research advisor, Jack Swigert, has asked her to benchmark the new system. 
    ``Since the Apollo is a distributed shared memory machine, memory access and communication times are not uniform,'' Valentine told Swigert. ``Communication is fast between processors that share the same memory subsystem, but it is slower between processors that are not on the same subsystem. Communication between the Apollo and machines in our lab is slower yet.'' 

    ``How is Apollo's port of the Message Passing Interface (MPI) working out?'' Swigert asked. 

    ``Not so well,'' Valentine replied. ``To do a broadcast of a message from one processor to all the other n-1 processors, they just do a sequence of n-1 sends. That really serializes things and kills the performance.'' 

    ``Is there anything you can do to fix that?'' 

    ``Yes,'' smiled Valentine. ``There is. Once the first processor has sent the message to another, those two can then send messages to two other hosts at the same time. Then there will be four hosts that can send, and so on.'' 

    ``Ah, so you can do the broadcast as a binary tree!'' 

    ``Not really a binary tree -- there are some particular features of our network that we should exploit. The interface cards we have allow each processor to simultaneously send messages to any number of the other processors connected to it. However, the messages don't necessarily arrive at the destinations at the same time -- there is a communication cost involved. In general, we need to take into account the communication costs for each link in our network topologies and plan accordingly to minimize the total time required to do a broadcast.''

    Input

    The input will describe the topology of a network connecting n processors. The first line of the input will be n, the number of processors, such that 1 <= n <= 100. 

    The rest of the input defines an adjacency matrix, A. The adjacency matrix is square and of size n x n. Each of its entries will be either an integer or the character x. The value of A(i,j) indicates the expense of sending a message directly from node i to node j. A value of x for A(i,j) indicates that a message cannot be sent directly from node i to node j. 

    Note that for a node to send a message to itself does not require network communication, so A(i,i) = 0 for 1 <= i <= n. Also, you may assume that the network is undirected (messages can go in either direction with equal overhead), so that A(i,j) = A(j,i). Thus only the entries on the (strictly) lower triangular portion of A will be supplied. 

    The input to your program will be the lower triangular section of A. That is, the second line of input will contain one entry, A(2,1). The next line will contain two entries, A(3,1) and A(3,2), and so on.

    Output

    Your program should output the minimum communication time required to broadcast a message from the first processor to all the other processors.

    Sample Input

    5
    50
    30 5
    100 20 50
    10 x x 10

    Sample Output

    35

    Source

    #include<iostream>
    #define INFINITE (0x6FFFFFFF)
    #define NOT_EXIST (-1)

    using namespace std;

    int main()
    {


    int Dist[100];
    int Edge[ 100 ][100];

    for( int i = 0 ; i < 100 ; ++i )
    {
    Dist[i] = INFINITE;
    for( int j = 0; j < 100; ++j )
    {
    if( i == j )
    {
    Edge[i][j] = 0;
    }
    else
    {
    Edge[i][j] = NOT_EXIST;
    }

    }
    }

    int N;
    cin >> N;

    for( int i = 1 ; i < N ; ++i )
    {
    for( int j = 0; j < i; ++j )
    {
    char str[20];
    cin >> str;
    if( str[0] >= '0' && str[0] <= '9' )
    {
    int tmp;
    sscanf(str,"%d" , &tmp);
    Edge[i][j] = tmp;
    Edge[j][i] = tmp;
    }
    }
    }

    Dist[0] = 0;

    for( int i = 0 ; i < N - 1 ; ++i )
    {
    for( int from = 0 ; from < N ; ++from )
    {
    for( int to = 0 ; to < N ; ++to )
    {
    if( Edge[from][to] != NOT_EXIST )
    {
    if( Dist[to] > Dist[from] + Edge[from][to] )
    {
    Dist[to] = Dist[from] + Edge[from][to];
    }
    }
    }
    }
    }

    int max = 0;
    for( int i = 0 ; i < N ; ++i )
    {
    if( Dist[i] > max )
    {
    max = Dist[i];
    }
    }
    cout << max << endl;


    return 0;
    }
  • 相关阅读:
    python 中 print函数的用法详解
    可转债操作一览
    Python基本数据类型
    python的列表
    理财的方法
    92、Multiple commands produce Info.plist 报错
    91、最新cocoaPods安装与使用
    90、引入头文件不提示
    89、instancetype和id的区别
    88、const、static、extern介绍
  • 原文地址:https://www.cnblogs.com/kking/p/2332901.html
Copyright © 2011-2022 走看看