zoukankan      html  css  js  c++  java
  • 1003. Emergency

    1003. Emergency (25)

    时间限制
    400 ms
    内存限制
    32000 kB
    代码长度限制
    16000 B
    判题程序
    Standard
    作者
    CHEN, Yue

    As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

    Input

    Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (<= 500) - the number of cities (and the cities are numbered from 0 to N-1), M - the number of roads, C1 and C2 - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2 and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.

    Output

    For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather.
    All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

    Sample Input
    5 6 0 2
    1 2 1 5 3
    0 1 1
    0 2 2
    0 3 1
    1 2 1
    2 4 1
    3 4 1
    
    Sample Output
    2 4
    #include <iostream>
    #include <fstream>
    #include <vector>
    #include <string>
    #include <algorithm>
    #include <map>
    #include <stack>
    #include <cmath>
    #include <queue>
    #include <set>
    #include <list>
    #include <stdlib.h>
    #include <string.h>
    #define REP(i,j,k) for(int i = j ; i < k ; ++i)
    #define MAXV (510)
    #define INF (0x6FFFFFFF)
    using namespace std;

    struct Node
    {
    int dist;
    int call;
    int team;
    int npath;
    bool known;

    void clear()
    {
    dist = INF;
    call = 0;
    team = 0;
    npath = 0;
    known = false;
    }
    };

    Node city[MAXV];
    int adj[MAXV][MAXV];
    int N,M,C1,C2;

    void dijkstra( int start , int end )
    {
    city[start].dist = 0;
    city[start].call = city[start].team;
    city[start].npath = 1;
    while(1)
    {
    int nearest_unknown = -1;
    int nearest = INF;

    REP(i,0,N)
    {
    if( city[i].known == false )
    {
    if( city[i].dist < nearest )
    {
    nearest = city[i].dist;
    nearest_unknown = i;
    }
    }

    }

    if( nearest_unknown == -1 )
    {
    break;
    }
    else
    {
    city[nearest_unknown].known = true;
    if( nearest_unknown == end )
    {
    return;
    }

    REP(i,0,N)
    {
    if( adj[nearest_unknown][i] != INF && city[i].known == false )
    {
    if( city[i].dist > city[nearest_unknown].dist + adj[nearest_unknown][i] )
    {
    city[i].dist = city[nearest_unknown].dist + adj[nearest_unknown][i];
    city[i].npath = city[nearest_unknown].npath;
    city[i].call = city[nearest_unknown].call + city[i].team;
    }
    else if( city[i].dist == city[nearest_unknown].dist + adj[nearest_unknown][i])
    {
    city[i].npath += city[nearest_unknown].npath ;
    if( city[i].call < city[nearest_unknown].call + city[i].team )
    {
    city[i].call = city[nearest_unknown].call + city[i].team;
    }
    }
    }
    }
    }

    }
    }
    int main()
    {

    //freopen("test.txt","r",stdin);

    cin >> N >> M >> C1 >> C2;

    REP(i,0,N)
    {
    city[i].clear();
    cin >> city[i].team;
    REP(j,0,N)
    {
    if( i == j )
    {
    adj[i][j] = 0;
    }
    else
    {
    adj[i][j] = INF;
    }

    }
    }

    REP(i,0,M)
    {
    int s,t,l;

    cin >> s >> t >> l;

    if( s!=t )
    {
    adj[s][t] = l >adj[s][t]? adj[s][t]:l ;
    adj[t][s] = l >adj[t][s]? adj[t][s]:l ;
    }

    }


    dijkstra(C1,C2);

    cout << city[C2].npath << " " << city[C2].call << endl;




    return 0;
    }


  • 相关阅读:
    Oracle 查看一个表对应的主键和外键的约束关系,查看的语句:
    openssl 生成p12文件错误
    XP SP3远程桌面无法连接Windows Server 2008/Vista
    windows 7 正确禁用 IPv6
    用正则表达式替换换行符
    Eclipse插件开发之定制向导(各方法说明)
    oepnvpn 配置自启动
    TNS12547: TNS:lost contact 错误解决
    redhat 5.5 U盘安装
    Hibernat 使用Criteria查询多对多关系(SET集合)条件
  • 原文地址:https://www.cnblogs.com/kking/p/2337684.html
Copyright © 2011-2022 走看看