Rightmost Digit
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12357 Accepted Submission(s): 4773
Problem Description
Given a positive integer N, you should output the most right digit of N^N.
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
Output
For each test case, you should output the rightmost digit of N^N.
Sample Input
2
3
4
Sample Output
7
6
Hint
In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7.
In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.Author
Ignatius.L
主要掌握模幂运算,而且求个位,一直求10的模
#include<stdio.h>
#include<iostream>
using namespace std;
int solve(long long n)
{
int t,b;
long long i;
b=n%10;
t=1;
if(b==0)return 0;
while(n)
{
if(n%2==1)
{
t*=b;
t%=10;
}
b*=b;
b%=10;
n/=2;
}
return t;
}
int main()
{
int T;
long long n;
cin>>T;
while(T--)
{
cin>>n;
cout<<solve(n)<<endl;
}
return 0;
}