zoukankan      html  css  js  c++  java
  • 2011ACM福州网络赛第一题 A Card Game(水题)

    A Card Game

    Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 4    Accepted Submission(s): 3


    Problem Description
    There are N cards on the table, whose front side is writen one integer number from 1 to M. We call one card "a type k card" if its number is k. The quantity of type i cards is a_i.
    Let's play a game with these cards. We divide these cards into M piles by random with the only constrains that the quantity of cards in i-th (indexed from 1) pile must exactly be a_i. The possbility of each card appears in i-th pile is directly proportional to the size of this pile. That is to say, if the size of a pile is A, the possibility for each card appears in this pile is A/N assuming that N is the amount of all cards. We choose pile 1 to start the game. Assuming the we now play this game at pile k, we randomly choose a card from pile k with the same possibility for all cards in it, remember the number written on this card and throw it away. If the number on the chosen card is j, we continue this game at pile j on next round. The game terminates when we are going to get a card from an empty pile.

    Now the question is, when the game ends, what is the possibility that all piles are empty?
     

    Input
    There is only one input file. The first line is the number of test cases T. T cases follow, each of which contains two lines. The first line is an integer M (1 <= M <= 100), the number of type of cards (and the number of piles, they are exactly the same). The second line contains M positive integers not greater than 1000, the i-th number of which is a_i.
     

    Output
    For each test case, output the possibility you are required to calculate. Answers are rounded to 6 numbers after the decimal point.(as shown in the sample output)
     

    Sample Input
    2 1 5 2 1 2
     

    Sample Output
    Case 1: 1.000000 Case 2: 0.333333
     
    水题,看代码:
    这样的题目很爽!
     
    #include<stdio.h>
    int main()
    {
        int T;
        int iCase=0;
        int a;
        int n;
        int ans,res;
        scanf("%d",&T);
        while(T--)
        {
            iCase++;
            scanf("%d",&n);
            scanf("%d",&ans);
            res=ans;
            for(int i=1;i<n;i++)
            {
                scanf("%d",&a);
                res+=a;
            }    
            printf("Case %d: %.6lf\n",iCase,(double)ans/res);
        }    
        return 0;
        
    }    
    

  • 相关阅读:
    Windows API—CreateEvent—创建事件
    C++的注册和回调
    Python内置模块-logging
    使用 C++ 处理 JSON 数据交换格式
    Python生成器
    5.Spring-Boot缓存数据之Redis
    6.Spring-Boot项目发布到独立的tomcat中
    7.Spring-Boot自定义Banner
    8.Spring-Boot之SpringJdbcTemplate整合Freemarker
    9.Spring-Boot之Mybatis-LogBack-Freemarker
  • 原文地址:https://www.cnblogs.com/kuangbin/p/2200549.html
Copyright © 2011-2022 走看看