zoukankan      html  css  js  c++  java
  • POJ 1013 Counterfeit Dollar(枚举)

    Counterfeit Dollar
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 30917   Accepted: 9680

    Description

    Sally Jones has a dozen Voyageur silver dollars. However, only eleven of the coins are true silver dollars; one coin is counterfeit even though its color and size make it indistinguishable from the real silver dollars. The counterfeit coin has a different weight from the other coins but Sally does not know if it is heavier or lighter than the real coins.
    Happily, Sally has a friend who loans her a very accurate balance scale. The friend will permit Sally three weighings to find the counterfeit coin. For instance, if Sally weighs two coins against each other and the scales balance then she knows these two coins are true. Now if Sally weighs
    one of the true coins against a third coin and the scales do not balance then Sally knows the third coin is counterfeit and she can tell whether it is light or heavy depending on whether the balance on which it is placed goes up or down, respectively.
    By choosing her weighings carefully, Sally is able to ensure that she will find the counterfeit coin with exactly three weighings.

    Input

    The first line of input is an integer n (n > 0) specifying the number of cases to follow. Each case consists of three lines of input, one for each weighing. Sally has identified each of the coins with the letters A--L. Information on a weighing will be given by two strings of letters and then one of the words ``up'', ``down'', or ``even''. The first string of letters will represent the coins on the left balance; the second string, the coins on the right balance. (Sally will always place the same number of coins on the right balance as on the left balance.) The word in the third position will tell whether the right side of the balance goes up, down, or remains even.

    Output

    For each case, the output will identify the counterfeit coin by its letter and tell whether it is heavy or light. The solution will always be uniquely determined.

    Sample Input

    1 
    ABCD EFGH even 
    ABCI EFJK up 
    ABIJ EFGH even 

    Sample Output

    K is the counterfeit coin and it is light. 

    Source

     
     
     
    枚举了所有的情况。12种,有一种假的,轻就设为-1,重为1,其余为0,至多12*2中情况。
    #include<stdio.h>
    #include<string.h>
    int main()
    {
    char str[9][20];
    int a[12];
    int T;
    scanf("%d",&T);
    while(T--)
    {
    for(int i=0;i<9;i++)scanf("%s",&str[i]);
    int res=-1;
    while(res<12)
    {
    int t;
    if(res==-1){res=0;t=1;}
    else if(a[res]==1) t=-1;
    else {res++;t=1;}
    for(int i=0;i<12;i++) a[i]=0;
    a[res]=t;
    int L=0,R=0;
    int len=strlen(str[0]);
    for(int i=0;i<len;i++) L+=a[str[0][i]-'A'];
    len=strlen(str[1]);
    for(int i=0;i<len;i++) R+=a[str[1][i]-'A'];
    if(strcmp(str[2],"even")==0)
    {
    if(L!=R)continue;
    }
    if(strcmp(str[2],"up")==0)
    if(L<=R)continue;
    if(strcmp(str[2],"down")==0)
    if(L>=R)continue;

    L=0,R=0;
    len=strlen(str[3]);
    for(int i=0;i<len;i++) L+=a[str[3][i]-'A'];
    len=strlen(str[4]);
    for(int i=0;i<len;i++) R+=a[str[4][i]-'A'];
    if(strcmp(str[5],"even")==0)
    {
    if(L!=R)continue;
    }
    if(strcmp(str[5],"up")==0)
    if(L<=R)continue;
    if(strcmp(str[5],"down")==0)
    if(L>=R)continue;

    L=0,R=0;
    len=strlen(str[6]);
    for(int i=0;i<len;i++) L+=a[str[6][i]-'A'];
    len=strlen(str[7]);
    for(int i=0;i<len;i++) R+=a[str[7][i]-'A'];
    if(strcmp(str[8],"even")==0)
    {
    if(L!=R)continue;
    }
    if(strcmp(str[8],"up")==0)
    if(L<=R)continue;
    if(strcmp(str[8],"down")==0)
    if(L>=R)continue;
    break;
    }
    printf("%c is the counterfeit coin and it is ",res+'A');
    if(a[res]==-1) printf("light.\n");
    else printf("heavy.\n");
    }
    return 0;
    }
  • 相关阅读:
    Cobbler学习之一--Fedora17下配置Cobbler安装环境
    linux下 tar解压 gz解压 bz2等各种解压文件使用方法
    linux性能检测工具
    firefox的plugin-container进程关闭方法
    部署额外域控制器,Active Directory
    利用yum下载软件包的三种方法
    HP iLo2 试用序列号
    (转)Linux下root密码丢失和运行级别错误的解决办法
    linux下的5个查找命令
    (转)CentOs上配置samba服务
  • 原文地址:https://www.cnblogs.com/kuangbin/p/2246372.html
Copyright © 2011-2022 走看看