zoukankan      html  css  js  c++  java
  • HDU 1023 Train Problem II (卡特兰数问题)

    Train Problem II

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 2830    Accepted Submission(s): 1562


    Problem Description
    As we all know the Train Problem I, the boss of the Ignatius Train Station want to know if all the trains come in strict-increasing order, how many orders that all the trains can get out of the railway.
     
    Input
    The input contains several test cases. Each test cases consists of a number N(1<=N<=100). The input is terminated by the end of file.
     
    Output
    For each test case, you should output how many ways that all the trains can get out of the railway.
     
    Sample Input
    1 2 3 10
     
    Sample Output
    1 2 5 16796
    Hint
    The result will be very large, so you may not process it by 32-bit integers.
     
    Author
    Ignatius.L
     
     
     
    简单的卡特兰数问题。
    卡特兰数介绍:
     
    这个已经可以做为模版了~~~
    //h( n ) = ( ( 4*n-2 )/( n+1 )*h( n-1 ) );


    #include<stdio.h>

    //*******************************
    //打表卡特兰数
    //第 n个 卡特兰数存在a[n]中,a[n][0]表示长度;
    //注意数是倒着存的,个位是 a[n][1] 输出时注意倒过来。
    //*********************************
    int a[105][100];
    void ktl()
    {
    int i,j,yu,len;
    a[2][0]=1;
    a[2][1]=2;
    a[1][0]=1;
    a[1][1]=1;
    len=1;
    for(i=3;i<101;i++)
    {
    yu=0;
    for(j=1;j<=len;j++)
    {
    int t=(a[i-1][j])*(4*i-2)+yu;
    yu=t/10;
    a[i][j]=t%10;
    }
    while(yu)
    {
    a[i][++len]=yu%10;
    yu/=10;
    }
    for(j=len;j>=1;j--)
    {
    int t=a[i][j]+yu*10;
    a[i][j]=t/(i+1);
    yu = t%(i+1);
    }
    while(!a[i][len])
    {
    len--;
    }
    a[i][0]=len;
    }

    }
    int main()
    {
    ktl();
    int n;
    while(scanf("%d",&n)!=EOF)
    {
    for(int i=a[n][0];i>0;i--)
    {
    printf("%d",a[n][i]);
    }
    puts("");
    }
    return 0;
    }
  • 相关阅读:
    php字符串
    碰撞检测
    javascript倒计时
    日期
    雪花那个飘
    VBS学习笔记(2): Call造成的麻烦
    VBS学习笔记(3): Array和Collection的不同
    NotepadAutomationDemo的代码V2
    VBS学习笔记(1): Set的取舍
    SQL Server之旅:(三)Attach mdf without ldf
  • 原文地址:https://www.cnblogs.com/kuangbin/p/2410519.html
Copyright © 2011-2022 走看看