zoukankan      html  css  js  c++  java
  • POJ 1696 Space Ant(极角排序)

    Space Ant
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 1799   Accepted: 1147

    Description

    The most exciting space discovery occurred at the end of the 20th century. In 1999, scientists traced down an ant-like creature in the planet Y1999 and called it M11. It has only one eye on the left side of its head and just three feet all on the right side of its body and suffers from three walking limitations:
    1. It can not turn right due to its special body structure.
    2. It leaves a red path while walking.
    3. It hates to pass over a previously red colored path, and never does that.

    The pictures transmitted by the Discovery space ship depicts that plants in the Y1999 grow in special points on the planet. Analysis of several thousands of the pictures have resulted in discovering a magic coordinate system governing the grow points of the plants. In this coordinate system with x and y axes, no two plants share the same x or y.
    An M11 needs to eat exactly one plant in each day to stay alive. When it eats one plant, it remains there for the rest of the day with no move. Next day, it looks for another plant to go there and eat it. If it can not reach any other plant it dies by the end of the day. Notice that it can reach a plant in any distance.
    The problem is to find a path for an M11 to let it live longest.
    Input is a set of (x, y) coordinates of plants. Suppose A with the coordinates (xA, yA) is the plant with the least y-coordinate. M11 starts from point (0,yA) heading towards plant A. Notice that the solution path should not cross itself and all of the turns should be counter-clockwise. Also note that the solution may visit more than two plants located on a same straight line.

    Input

    The first line of the input is M, the number of test cases to be solved (1 <= M <= 10). For each test case, the first line is N, the number of plants in that test case (1 <= N <= 50), followed by N lines for each plant data. Each plant data consists of three integers: the first number is the unique plant index (1..N), followed by two positive integers x and y representing the coordinates of the plant. Plants are sorted by the increasing order on their indices in the input file. Suppose that the values of coordinates are at most 100.

    Output

    Output should have one separate line for the solution of each test case. A solution is the number of plants on the solution path, followed by the indices of visiting plants in the path in the order of their visits.

    Sample Input

    2
    10
    1 4 5
    2 9 8
    3 5 9
    4 1 7
    5 3 2
    6 6 3
    7 10 10
    8 8 1
    9 2 4
    10 7 6
    14
    1 6 11
    2 11 9
    3 8 7
    4 12 8
    5 9 20
    6 3 2
    7 1 6
    8 2 13
    9 15 1
    10 14 17
    11 13 19
    12 5 18
    13 7 3
    14 10 16
    

    Sample Output

    10 8 7 3 4 9 5 6 2 1 10
    14 9 10 11 5 12 8 7 6 13 4 14 1 3 2
    

    Source

     
     
     题意:一只蚂蚁,只会向左转,现在给出平面上很多个点,求解一种走法,能使得蚂蚁能经过的点最多,每个顶点该蚂蚁只能经过一次,且所行走的路线不能发生交叉.
        对于题目所输入的点,先找出最左下方的顶点(即纵坐标最小的顶点),然后对剩下的顶点按照对与左下点的极角排序,然后反复找最左下的点,反复进行极角排序,同时记录排序后左下的顶点.
        极角排序方法:利用叉积,看向量p1和p2的叉积是否小于零,是则说明p1在p2逆时针方向,即p1的极角比p2的大,极角相同则按离p0距离降序排序.
     
     
    #include<stdio.h>
    #include<algorithm>
    #include<iostream>
    using namespace std;

    const int MAXN=55;
    struct Node
    {
    int x,y;
    int num;
    };
    Node p[MAXN],res[MAXN];

    int pos;

    int cross(Node p0,Node p1,Node p2)
    {

    return (p1.x-p0.x)*(p2.y-p0.y)-(p2.x-p0.x)*(p1.y-p0.y);
    }
    int dis(Node p1,Node p2)
    {
    return (p2.x-p1.x)*(p2.x-p1.x)+(p2.y-p1.y)*(p2.y-p1.y);
    }

    bool cmp(Node p1,Node p2)
    {
    int tmp=cross(p[pos],p1,p2);
    if(tmp>0) return true;
    else if(tmp==0&&dis(p[pos],p1)<dis(p[pos],p2)) return true;
    else return false;
    }

    int main()
    {
    int T;
    scanf("%d",&T);
    int n;
    while(T--)
    {
    scanf("%d",&n);
    for(int i=0;i<n;i++)
    {
    scanf("%d%d%d",&p[i].num,&p[i].x,&p[i].y);
    if(p[i].y<p[0].y) swap(p[0],p[i]);
    }
    int j=pos=0;
    sort(p+1,p+n,cmp);
    res[j++]=p[pos++];
    for(int i=2;i<n;i++)
    {
    sort(p+pos,p+n,cmp);
    res[j++]=p[pos++];
    }
    res[j++]=p[pos++];
    printf("%d",j);
    for(int i=0;i<j;i++)
    printf(" %d",res[i].num);
    printf("\n");
    }
    return 0;
    }
  • 相关阅读:
    Unity制作地形的常用插件之GAIA
    JetBrains套装免费学生授权申请(IntelliJ, ReSharper, WebStorm...)
    Unity2D游戏开发之保卫萝卜
    Unity制作出《超级马里奥》的2D和3D混合效果
    Unity2019.1中文技术手册离线版
    暗黑战神! Unity3D网游ARPG实战案例
    Unity移动端入门
    win10如何查看电脑端口使用情况
    自制FastDFS文件服务器虚拟机分享
    MySQL:使用SQL语句删除所有索引
  • 原文地址:https://www.cnblogs.com/kuangbin/p/2417046.html
Copyright © 2011-2022 走看看