zoukankan      html  css  js  c++  java
  • POJ 2769 Reduced ID Numbers

    Reduced ID Numbers
    Time Limit: 2000MS   Memory Limit: 65536K
    Total Submissions: 7494   Accepted: 3029

    Description

    T. Chur teaches various groups of students at university U. Every U-student has a unique Student Identification Number (SIN). A SIN s is an integer in the range 0 ≤ s ≤ MaxSIN with MaxSIN = 106-1. T. Chur finds this range of SINs too large for identification within her groups. For each group, she wants to find the smallest positive integer m, such that within the group all SINs reduced modulo m are unique.

    Input

    On the first line of the input is a single positive integer N, telling the number of test cases (groups) to follow. Each case starts with one line containing the integer G (1 ≤ G ≤ 300): the number of students in the group. The following G lines each contain one SIN. The SINs within a group are distinct, though not necessarily sorted.

    Output

    For each test case, output one line containing the smallest modulus m, such that all SINs reduced modulo m are distinct.

    Sample Input

    2
    1
    124866
    3
    124866
    111111
    987651
    

    Sample Output

    1
    8
    

    Source

     
     
     
    枚举法。。。。
    注意清除标志时,只要清除用过的记录,直接memset会超时的
     
    #include<stdio.h>
    #include<string.h>
    int a[310];
    bool flag[1000010];
    int set[310];
    void clear(int n)
    {
        for(int i=0;i<n;i++)
          flag[set[i]]=false;
    }    
    int main()
    {
        int j;
        int T;
        int n;
        int m;
        bool ff;
        scanf("%d",&T);
        while(T--)
        {
            scanf("%d",&n);
            for(int i=0;i<n;i++) scanf("%d",&a[i]);
            memset(flag,false,sizeof(flag));
            m=0;
            for(j=n;;j++)
            {
                clear(m);
                m=0;
                ff=true;
                for(int i=0;i<n;i++)
                {
                    int t=a[i]%j;
                    if(flag[t]==true)
                    {
                        ff=false;
                        break;
                    }    
                    else
                    {
                        flag[t]=true;
                        set[m++]=t;
                    }    
                }    
                if(ff) break;
            }    
            printf("%d\n",j);
            
        }    
        return 0;
    }    
  • 相关阅读:
    jsp int转String or String转int 方法
    log4j详细使用教程
    SQL 查询当天,本月,本周的记录
    1012Linux流编程的一些知识点
    myeclipse过期以后提示过期以后怎么办?!
    mysql常用命令
    Myeclipse文件没出错,但是项目上显示有错的解决办法
    java的一些命名规范吧
    mysql 按照时间查询
    struts1.x和struts2.x之间的一些区别
  • 原文地址:https://www.cnblogs.com/kuangbin/p/2490814.html
Copyright © 2011-2022 走看看