zoukankan      html  css  js  c++  java
  • POJ 2632 Crashing Robots(水模拟)

    Crashing Robots
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 5453   Accepted: 2382

    Description

    In a modernized warehouse, robots are used to fetch the goods. Careful planning is needed to ensure that the robots reach their destinations without crashing into each other. Of course, all warehouses are rectangular, and all robots occupy a circular floor space with a diameter of 1 meter. Assume there are N robots, numbered from 1 through N. You will get to know the position and orientation of each robot, and all the instructions, which are carefully (and mindlessly) followed by the robots. Instructions are processed in the order they come. No two robots move simultaneously; a robot always completes its move before the next one starts moving.
    A robot crashes with a wall if it attempts to move outside the area of the warehouse, and two robots crash with each other if they ever try to occupy the same spot.

    Input

    The first line of input is K, the number of test cases. Each test case starts with one line consisting of two integers, 1 <= A, B <= 100, giving the size of the warehouse in meters. A is the length in the EW-direction, and B in the NS-direction.
    The second line contains two integers, 1 <= N, M <= 100, denoting the numbers of robots and instructions respectively.
    Then follow N lines with two integers, 1 <= Xi <= A, 1 <= Yi <= B and one letter (N, S, E or W), giving the starting position and direction of each robot, in order from 1 through N. No two robots start at the same position.

    Figure 1: The starting positions of the robots in the sample warehouse

    Finally there are M lines, giving the instructions in sequential order.
    An instruction has the following format:
    < robot #> < action> < repeat>
    Where is one of
    • L: turn left 90 degrees,
    • R: turn right 90 degrees, or
    • F: move forward one meter,

    and 1 <= < repeat> <= 100 is the number of times the robot should perform this single move.

    Output

    Output one line for each test case:
    • Robot i crashes into the wall, if robot i crashes into a wall. (A robot crashes into a wall if Xi = 0, Xi = A + 1, Yi = 0 or Yi = B + 1.)
    • Robot i crashes into robot j, if robots i and j crash, and i is the moving robot.
    • OK, if no crashing occurs.

    Only the first crash is to be reported.

    Sample Input

    4
    5 4
    2 2
    1 1 E
    5 4 W
    1 F 7
    2 F 7
    5 4
    2 4
    1 1 E
    5 4 W
    1 F 3
    2 F 1
    1 L 1
    1 F 3
    5 4
    2 2
    1 1 E
    5 4 W
    1 L 96
    1 F 2
    5 4
    2 3
    1 1 E
    5 4 W
    1 F 4
    1 L 1
    1 F 20

    Sample Output

    Robot 1 crashes into the wall
    Robot 1 crashes into robot 2
    OK
    Robot 1 crashes into robot 2

    Source

     
     
    /*
    
    POJ 2632
    模拟
    */
    
    #include<stdio.h>
    #include<iostream>
    #include<string.h>
    using namespace std;
    const int MAXN=110;
    int map[MAXN][MAXN];
    struct Node
    {
        int x,y;
        int dir;//0,1,2,3:N,W,S,E
    }rob[MAXN];
    int move[4][2]={{0,1},{-1,0},{0,-1},{1,0}};
    int main()
    {
     //   freopen("in.txt","r",stdin);
     //   freopen("out.txt","w",stdo);
    ut    int T;
        int A,B;
        int N,M;
        char str[10];
        scanf("%d",&T);
        while(T--)
        {
            scanf("%d%d",&A,&B);
            scanf("%d%d",&N,&M);
            memset(map,0,sizeof(map));
            for(int i=1;i<=N;i++)
            {
                scanf("%d%d",&rob[i].x,&rob[i].y);
                map[rob[i].x][rob[i].y]=i;
                scanf("%s",&str);
                if(str[0]=='N') rob[i].dir=0;
                else if(str[0]=='W') rob[i].dir=1;
                else if(str[0]=='S') rob[i].dir=2;
                else if(str[0]=='E') rob[i].dir=3;
            }
            int t1,t2;
            bool flag=false;
            while(M--)
            {
                scanf("%d%s%d",&t1,&str,&t2);
                if(flag)continue;//第一次相撞已经记录完了
                if(str[0]=='L')
                {
                    rob[t1].dir+=t2;
                    rob[t1].dir%=4;
    
                }
                else if(str[0]=='R')
                {
                    rob[t1].dir-=t2;
                    rob[t1].dir%=4;
                    rob[t1].dir=(rob[t1].dir+4)%4;//化为正的
                }
                else
                {
                    int x=rob[t1].x;
                    int y=rob[t1].y;
                    while(t2--)
                    {
                        x=rob[t1].x;
                        y=rob[t1].y;
                        x+=move[rob[t1].dir][0];
                        y+=move[rob[t1].dir][1];
                        if(x<=0||x>A||y<=0||y>B)
                        {
                            printf("Robot %d crashes into the wall\n",t1);
                            flag=true;
                            break;
                        }
                        else if(map[x][y]!=0)
                        {
                            printf("Robot %d crashes into robot %d\n",t1,map[x][y]);
                            flag=true;
                            break;
                        }
                        else
                        {
                            map[x][y]=t1;
                            map[rob[t1].x][rob[t1].y]=0;
                            rob[t1].x=x;
                            rob[t1].y=y;
                        }
                    }
                }
    
            }
            if(!flag)printf("OK\n");
        }
        return 0;
    }
  • 相关阅读:
    最全的常用正则表达式大全——包括校验数字、字符、一些特殊的需求等等
    xcode6+ios8最新真机调试教程
    新手学习ios开发的辅助工具
    IOS事件传递之hitTest:withEvent
    <转>Singletons in Objective-C
    iOS机身振动提醒
    (CGSize)sizeWithFont:(UIFont *)font constrainedToSize:(CGSize)size lineBreakMode:(NSLineBreakMode)lineBreakMode
    对数组进行排序
    字符串去掉空格问题
    NSArray排序方法
  • 原文地址:https://www.cnblogs.com/kuangbin/p/2636292.html
Copyright © 2011-2022 走看看