zoukankan      html  css  js  c++  java
  • POJ 2996 Help Me with the Game(水模拟)

    Help Me with the Game
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 2426   Accepted: 1571

    Description

    Your task is to read a picture of a chessboard position and print it in the chess notation.

    Input

    The input consists of an ASCII-art picture of a chessboard with chess pieces on positions described by the input. The pieces of the white player are shown in upper-case letters, while the black player's pieces are lower-case letters. The letters are one of "K" (King), "Q" (Queen), "R" (Rook), "B" (Bishop), "N" (Knight), or "P" (Pawn). The chessboard outline is made of plus ("+"), minus ("-"), and pipe ("|") characters. The black fields are filled with colons (":"), white fields with dots (".").

    Output

    The output consists of two lines. The first line consists of the string "White: ", followed by the description of positions of the pieces of the white player. The second line consists of the string "Black: ", followed by the description of positions of the pieces of the black player.

    The description of the position of the pieces is a comma-separated list of terms describing the pieces of the appropriate player. The description of a piece consists of a single upper-case letter that denotes the type of the piece (except for pawns, for that this identifier is omitted). This letter is immediatelly followed by the position of the piece in the standard chess notation -- a lower-case letter between "a" and "h" that determines the column ("a" is the leftmost column in the input) and a single digit between 1 and 8 that determines the row (8 is the first row in the input).

    The pieces in the description must appear in the following order: King("K"), Queens ("Q"), Rooks ("R"), Bishops ("B"), Knights ("N"), and pawns. Note that the numbers of pieces may differ from the initial position because of capturing the pieces and the promotions of pawns. In case two pieces of the same type appear in the input, the piece with the smaller row number must be described before the other one if the pieces are white, and the one with the larger row number must be described first if the pieces are black. If two pieces of the same type appear in the same row, the one with the smaller column letter must appear first.

    Sample Input

    +---+---+---+---+---+---+---+---+
    |.r.|:::|.b.|:q:|.k.|:::|.n.|:r:|
    +---+---+---+---+---+---+---+---+
    |:p:|.p.|:p:|.p.|:p:|.p.|:::|.p.|
    +---+---+---+---+---+---+---+---+
    |...|:::|.n.|:::|...|:::|...|:p:|
    +---+---+---+---+---+---+---+---+
    |:::|...|:::|...|:::|...|:::|...|
    +---+---+---+---+---+---+---+---+
    |...|:::|...|:::|.P.|:::|...|:::|
    +---+---+---+---+---+---+---+---+
    |:P:|...|:::|...|:::|...|:::|...|
    +---+---+---+---+---+---+---+---+
    |.P.|:::|.P.|:P:|...|:P:|.P.|:P:|
    +---+---+---+---+---+---+---+---+
    |:R:|.N.|:B:|.Q.|:K:|.B.|:::|.R.|
    +---+---+---+---+---+---+---+---+
    

    Sample Output

    White: Ke1,Qd1,Ra1,Rh1,Bc1,Bf1,Nb1,a2,c2,d2,f2,g2,h2,a3,e4
    Black: Ke8,Qd8,Ra8,Rh8,Bc8,Ng8,Nc6,a7,b7,c7,d7,e7,f7,h7,h6

    Source

     
     
     
     
    /*
    POJ 2996
    水模拟
    注意看清楚题目,细节注意,尤其是输出顺序
    */
    
    #include<stdio.h>
    #include<string.h>
    #include<iostream>
    using namespace std;
    const int MAXN=40;
    char map[MAXN][MAXN];
    
    int main()
    {
       // freopen("in.txt","r",stdin);
      //  freopen("out.txt","w",stdout);
        for(int i=0;i<17;i++)
          scanf("%s",&map[i]);
        printf("White: ");
        bool flag=false;
        for(int i=15;i>=1;i-=2)//注意循环的顺序
        {
            if(flag)break;
            for(int j=2;j<=30;j+=4)
            {
                if(map[i][j]=='K')
                {
                    printf("K");
                    printf("%c%d",'a'+j/4,8-i/2);
                    flag=true;
                    break;
                }
            }
        }
        for(int i=15;i>=1;i-=2)
        {
            for(int j=2;j<=30;j+=4)
            {
                if(map[i][j]=='Q')
                {
                    printf(",Q");
                    printf("%c%d",'a'+j/4,8-i/2);
                }
            }
        }
        for(int i=15;i>=1;i-=2)
        {
            for(int j=2;j<=30;j+=4)
            {
                if(map[i][j]=='R')
                {
                    printf(",R");
                    printf("%c%d",'a'+j/4,8-i/2);
                }
            }
        }
        for(int i=15;i>=1;i-=2)
        {
            for(int j=2;j<=30;j+=4)
            {
                if(map[i][j]=='B')
                {
                    printf(",B");
                    printf("%c%d",'a'+j/4,8-i/2);
                }
            }
        }
        for(int i=15;i>=1;i-=2)
        {
            for(int j=2;j<=30;j+=4)
            {
                if(map[i][j]=='N')
                {
                    printf(",N");
                    printf("%c%d",'a'+j/4,8-i/2);
                }
            }
        }
        for(int i=15;i>=1;i-=2)
        {
            for(int j=2;j<=30;j+=4)
            {
                if(map[i][j]=='P')
                {
                    printf(",");
                    printf("%c%d",'a'+j/4,8-i/2);
                }
            }
        }
        printf("\n");
    
    
    
    
        printf("Black: ");
        flag=false;
        for(int i=1;i<=15;i+=2)//顺序要变化
        {
            if(flag)break;
            for(int j=2;j<=30;j+=4)
            {
                if(map[i][j]=='k')
                {
                    printf("K");
                    printf("%c%d",'a'+j/4,8-i/2);
                    flag=true;
                    break;
                }
            }
        }
        for(int i=1;i<=15;i+=2)
        {
            for(int j=2;j<=30;j+=4)
            {
                if(map[i][j]=='q')
                {
                    printf(",Q");
                    printf("%c%d",'a'+j/4,8-i/2);
                }
            }
        }
        for(int i=1;i<=15;i+=2)
        {
            for(int j=2;j<=30;j+=4)
            {
                if(map[i][j]=='r')
                {
                    printf(",R");
                    printf("%c%d",'a'+j/4,8-i/2);
                }
            }
        }
        for(int i=1;i<=15;i+=2)
        {
            for(int j=2;j<=30;j+=4)
            {
                if(map[i][j]=='b')
                {
                    printf(",B");
                    printf("%c%d",'a'+j/4,8-i/2);
                }
            }
        }
        for(int i=1;i<=15;i+=2)
        {
            for(int j=2;j<=30;j+=4)
            {
                if(map[i][j]=='n')
                {
                    printf(",N");
                    printf("%c%d",'a'+j/4,8-i/2);
                }
            }
        }
        for(int i=1;i<=15;i+=2)
        {
            for(int j=2;j<=30;j+=4)
            {
                if(map[i][j]=='p')
                {
                    printf(",");
                    printf("%c%d",'a'+j/4,8-i/2);
                }
            }
        }
        printf("\n");
    
    
        return 0;
    
    
    }
  • 相关阅读:
    econtrol窗体设计器
    脚本引擎注册将要使用的类,属性,方法,函数
    FastReport开发手册
    控制钱箱,客显,打印
    Laravel渴求式加载(比较容易理解理解load与with关系)
    50分钟学会Laravel 50个小技巧(基于laravel5.2,仅供参考)
    日期选择器date、week、time、datetime、datetimelocal类型
    input type=date时,时间数据回填,报错The specified value "2019040418" does not conform to the required format...
    Laravel技巧:使用load、with预加载 区别
    arcengine,C#实现分页打印预览
  • 原文地址:https://www.cnblogs.com/kuangbin/p/2636492.html
Copyright © 2011-2022 走看看