zoukankan      html  css  js  c++  java
  • POJ 1850 Code(排列数组)

    Code
    Time Limit: 1000MS   Memory Limit: 30000K
    Total Submissions: 6093   Accepted: 2865

    Description

    Transmitting and memorizing information is a task that requires different coding systems for the best use of the available space. A well known system is that one where a number is associated to a character sequence. It is considered that the words are made only of small characters of the English alphabet a,b,c, ..., z (26 characters). From all these words we consider only those whose letters are in lexigraphical order (each character is smaller than the next character).

    The coding system works like this:
    • The words are arranged in the increasing order of their length.
    • The words with the same length are arranged in lexicographical order (the order from the dictionary).
    • We codify these words by their numbering, starting with a, as follows:
    a - 1
    b - 2
    ...
    z - 26
    ab - 27
    ...
    az - 51
    bc - 52
    ...
    vwxyz - 83681
    ...

    Specify for a given word if it can be codified according to this coding system. For the affirmative case specify its code.

    Input

    The only line contains a word. There are some constraints:
    • The word is maximum 10 letters length
    • The English alphabet has 26 characters.

    Output

    The output will contain the code of the given word, or 0 if the word can not be codified.

    Sample Input

    bf

    Sample Output

    55

    Source

     
     
     
     
    就是排列组合。。
    先算长度小的,再算长度相同的。
    打表求出组合数
     
    #include<stdio.h>
    #include<iostream>
    #include<string.h>
    using namespace std;
    
    int C[27][27];
    void init()
    {
        C[0][0]=1;
        C[1][0]=C[1][1]=1;
        for(int i=2;i<27;i++)
        {
            C[i][0]=1;
            for(int j=1;j<i;j++)
               C[i][j]=C[i-1][j]+C[i-1][j-1];
            C[i][i]=1;
        }
    }
    
    char str[20];
    
    int main()
    {
        init();
    
        while(scanf("%s",&str)!=EOF)
        {
             bool flag=true;
             int len=strlen(str);
             for(int i=1;i<len;i++)
               if(str[i]<=str[i-1])
               {
                   flag=false;
                   break;
               }
            if(!flag)
            {
                printf("0\n");
                continue;
            }
            int ans=0;
    
            int t=len-1;
            while(t>0)
            {
                ans+=C[26][t];
                t--;
            }
            for(int i=0;i<len;i++)
            {
                t=str[i]-'a';
                int t1;
                if(i==0)t1=0;
                else t1=str[i-1]-'a'+1;
                while(t>t1)
                {
                    ans+=C[26-t][len-1-i];
                    t--;
                }
    
            }
            printf("%d\n",ans+1);
        }
        return 0;
    }
  • 相关阅读:
    vue.js 快速入门
    简洁的MVC思想框架——Nancy(Post操作与外部引用css和JS)
    简洁的MVC思想框架——Nancy(环境配置与Get操作)
    iOS开发之注册推送通知权限
    iOS开发之数组排序
    iOS开发之打包上传报错: ERROR ITMS-90087/ERROR ITMS-90125
    iOS开发之HTTP与HTTPS网络请求
    iOS开发之GCD同步主线程、异步主线程
    iOS开发之获取时间戳方法
    iOS开发之将字典、数组转为JSON字符串方法
  • 原文地址:https://www.cnblogs.com/kuangbin/p/2645793.html
Copyright © 2011-2022 走看看