zoukankan      html  css  js  c++  java
  • POJ 2246 ZOJ 1094 Matrix Chain Multiplication(简单题)

    Matrix Chain Multiplication
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 1678   Accepted: 1080

    Description

    Suppose you have to evaluate an expression like A*B*C*D*E where A,B,C,D and E are matrices.
    Since matrix multiplication is associative, the order in which multiplications are performed is arbitrary. However, the number of elementary multiplications needed strongly depends on the evaluation order you choose.
    For example, let A be a 50*10 matrix, B a 10*20 matrix and C a 20*5 matrix.
    There are two different strategies to compute A*B*C, namely (A*B)*C and A*(B*C).
    The first one takes 15000 elementary multiplications, but the second one only 3500.

    Your job is to write a program that determines the number of elementary multiplications needed for a given evaluation strategy.

    Input

    Input consists of two parts: a list of matrices and a list of expressions.
    The first line of the input file contains one integer n (1 <= n <= 26), representing the number of matrices in the first part. The next n lines each contain one capital letter, specifying the name of the matrix, and two integers, specifying the number of rows and columns of the matrix.
    The second part of the input file strictly adheres to the following syntax (given in EBNF):
    SecondPart = Line { Line } 
    Line = Expression
    Expression = Matrix | "(" Expression Expression ")"
    Matrix = "A" | "B" | "C" | ... | "X" | "Y" | "Z"

    Output

    For each expression found in the second part of the input file, print one line containing the word "error" if evaluation of the expression leads to an error due to non-matching matrices. Otherwise print one line containing the number of elementary multiplications needed to evaluate the expression in the way specified by the parentheses.

    Sample Input

    9
    A 50 10
    B 10 20
    C 20 5
    D 30 35
    E 35 15
    F 15 5
    G 5 10
    H 10 20
    I 20 25
    A
    B
    C
    (AA)
    (AB)
    (AC)
    (A(BC))
    ((AB)C)
    (((((DE)F)G)H)I)
    (D(E(F(G(HI)))))
    ((D(EF))((GH)I))
    

    Sample Output

    0
    0
    0
    error
    10000
    error
    3500
    15000
    40500
    47500
    15125
    

    Source

     
    #include<stdio.h>
    #include<algorithm>
    #include<iostream>
    #include<string.h>
    using namespace std;
    struct Node
    {
        int mults;//已经做过的乘法次数
        int row;//行数
        int col;//列数
    };
    char str[1000];
    int pos;
    int flag;
    int rows[30];
    int cols[30];
    Node get_M()
    {
        Node t;
        if(str[pos]=='(')
           {
               Node t1,t2;
               pos++;
               t1=get_M();
               t2=get_M();
               pos++;//右括号
               if(t1.col!=t2.row)
               {
                   flag=false;
               }
               t.row=t1.row;
               t.col=t2.col;
               t.mults=t1.mults+t2.mults+t1.row*t1.col*t2.col;
           }
           else
           {
               t.row=rows[str[pos]-'A'];
               t.col=cols[str[pos]-'A'];
               t.mults=0;
               pos++;
           }
           return t;
    }
    char s[10];
    int main()
    {
        int n;
        int u,v;
        scanf("%d",&n);
        while(n--)
        {
            scanf("%s%d%d",&s,&u,&v);
            rows[s[0]-'A']=u;
            cols[s[0]-'A']=v;
        }
        while(scanf("%s",&str)!=EOF)
        {
            pos=0;
            flag=true;
            Node t=get_M();
            if(!flag)printf("error\n");
            else printf("%d\n",t.mults);
        }
        return 0;
    }
  • 相关阅读:
    bzoj 1444: [Jsoi2009]有趣的游戏【AC自动机+dp+高斯消元】
    bzoj 3270: 博物馆【dp+高斯消元】
    bzoj 3105: [cqoi2013]新Nim游戏【线性基+贪心】
    bzoj 1923: [Sdoi2010]外星千足虫【高斯消元】
    bzoj 3629: [JLOI2014]聪明的燕姿【线性筛+dfs】
    bzoj 1296: [SCOI2009]粉刷匠【dp+背包dp】
    bzoj 3329: Xorequ【数位dp+矩阵乘法】
    bzoj 1306: [CQOI2009]match循环赛【dfs+剪枝】
    bzoj 4720: [Noip2016]换教室【期望dp】
    bzoj 2257: [Jsoi2009]瓶子和燃料【裴蜀定理+gcd】
  • 原文地址:https://www.cnblogs.com/kuangbin/p/2679289.html
Copyright © 2011-2022 走看看