zoukankan      html  css  js  c++  java
  • HDU 4296 Buildings 第37届ACM/ICPC 成都赛区网络赛1009题 (贪心)

    Buildings

    Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 155    Accepted Submission(s): 72


    Problem Description
      Have you ever heard the story of Blue.Mary, the great civil engineer? Unlike Mr. Wolowitz, Dr. Blue.Mary has accomplished many great projects, one of which is the Guanghua Building.
      The public opinion is that Guanghua Building is nothing more than one of hundreds of modern skyscrapers recently built in Shanghai, and sadly, they are all wrong. Blue.Mary the great civil engineer had try a completely new evolutionary building method in project of Guanghua Building. That is, to build all the floors at first, then stack them up forming a complete building.
      Believe it or not, he did it (in secret manner). Now you are face the same problem Blue.Mary once stuck in: Place floors in a good way.
      Each floor has its own weight wi and strength si. When floors are stacked up, each floor has PDV(Potential Damage Value) equal to (Σwj)-si, where (Σwj) stands for sum of weight of all floors above.
      Blue.Mary, the great civil engineer, would like to minimize PDV of the whole building, denoted as the largest PDV of all floors.
      Now, it’s up to you to calculate this value.
     
    Input
      There’re several test cases.
      In each test case, in the first line is a single integer N (1 <= N <= 105) denoting the number of building’s floors. The following N lines specify the floors. Each of them contains two integers wi and si (0 <= wi, si <= 100000) separated by single spaces.
      Please process until EOF (End Of File).
     
    Output
      For each test case, your program should output a single integer in a single line - the minimal PDV of the whole building.
      If no floor would be damaged in a optimal configuration (that is, minimal PDV is non-positive) you should output 0.
     
    Sample Input
    3 10 6 2 3 5 4 2 2 2 2 2 3 10 3 2 5 3 3
     
    Sample Output
    1 0 2
     
    Source
     
    Recommend
    liuyiding
     
    贪心的题目。
    很水,排序方法看代码。
    我是一个一个试出来的,现在还没有证出来。
    //1009
    #include<stdio.h>
    #include<iostream>
    #include<map>
    #include<set>
    #include<algorithm>
    #include<string.h>
    #include<stdlib.h>
    using namespace std;
    const int MAXN=100010;
    struct Node
    {
        int w,s;
    }tt[MAXN];
    
    
    bool cmp2(Node a,Node b)
    {
        return a.w - b.s< b.w - a.s;
    }
    int main()
    {
        int n;
        while(scanf("%d",&n)!=EOF)
        {
            for(int i=0;i<n;i++)
              scanf("%d%d",&tt[i].w,&tt[i].s);
            sort(tt,tt+n,cmp2);
            long long ans=0;
            long long s=0;
    
    
            for(int i=0;i<n;i++)
            {
                if(s-tt[i].s>ans)ans=s-tt[i].s;
                s+=tt[i].w;
            }
    
            printf("%I64d\n",ans);
        }
        return 0;
    }
  • 相关阅读:
    TCP/IP详解卷:协议 第八章简要总结
    渗透测试1
    以前的实验博客地址,以前使用csdn
    day03---Node (05)
    day03---Vue(04)
    day03---Vue(03)
    day03---ES6入门(02)
    day03---前端开发和前端开发工具(01)
    Docker实战总结
    ETL之Kettle入门
  • 原文地址:https://www.cnblogs.com/kuangbin/p/2687762.html
Copyright © 2011-2022 走看看