zoukankan      html  css  js  c++  java
  • HDU 2709 Sumsets(递推)

    Sumsets

    Time Limit: 6000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 1030    Accepted Submission(s): 406


    Problem Description
    Farmer John commanded his cows to search for different sets of numbers that sum to a given number. The cows use only numbers that are an integer power of 2. Here are the possible sets of numbers that sum to 7:

    1) 1+1+1+1+1+1+1
    2) 1+1+1+1+1+2
    3) 1+1+1+2+2
    4) 1+1+1+4
    5) 1+2+2+2
    6) 1+2+4

    Help FJ count all possible representations for a given integer N (1 <= N <= 1,000,000).
     
    Input
    A single line with a single integer, N.
     
    Output
    The number of ways to represent N as the indicated sum. Due to the potential huge size of this number, print only last 9 digits (in base 10 representation).
     
    Sample Input
    7
     
    Sample Output
    6
     
    Source
     
    Recommend
    teddy

    设a[n]为和为 n 的种类数;

    根据题目可知,加数为2的N次方,即 n 为奇数时等于它前一个数 n-1 的种类数 a[n-1] ,若 n 为偶数时分加数中有无 1 讨论,即关键是对 n 为偶数时进行讨论:

    1.n为奇数,a[n]=a[n-1]

    2.n为偶数:

    (1)如果加数里含1,则一定至少有两个1,即对n-2的每一个加数式后面 +1+1,总类数为a[n-2];

    (2)如果加数里没有1,即对n/2的每一个加数式乘以2,总类数为a[n-2];

    所以总的种类数为:a[n]=a[n-2]+a[n/2];

    //============================================================================
    // Name        : HDU2709.cpp
    // Author      : 
    // Version     :
    // Copyright   : Your copyright notice
    // Description : Hello World in C++, Ansi-style
    //============================================================================
    /*
     * 设a[n]为和为 n 的种类数;
    
    根据题目可知,加数为2的N次方,即 n 为奇数时等于它前一个数 n-1 的种类数 a[n-1] ,若 n 为偶数时分加数中有无 1 讨论,即关键是对 n 为偶数时进行讨论:
    
    1.n为奇数,a[n]=a[n-1]
    
    2.n为偶数:
    
    (1)如果加数里含1,则一定至少有两个1,即对n-2的每一个加数式后面 +1+1,总类数为a[n-2];
    
    (2)如果加数里没有1,即对n/2的每一个加数式乘以2,总类数为a[n-2];
    
    所以总的种类数为:a[n]=a[n-2]+a[n/2];
     */
    
    
    #include <iostream>
    #include <string.h>
    #include <algorithm>
    #include <stdio.h>
    using namespace std;
    const int MAXN=1000010;
    const int MOD=1000000000;
    int a[MAXN];
    void init()
    {
        a[0]=a[1]=1;
        for(int i=2;i<MAXN;i++)
        {
            if(i%2)a[i]=a[i-1];
            else
            {
                a[i]=a[i-2]+a[i/2];
                a[i]%=MOD;
            }
        }
    }
    int main()
    {
        //freopen("in.txt","r",stdin);
        //freopen("out.txt","w",stdout);
        init();
        int n;
        while(scanf("%d",&n)==1)
        {
            printf("%d\n",a[n]);
        }
        return 0;
    }
    人一我百!人十我万!永不放弃~~~怀着自信的心,去追逐梦想
  • 相关阅读:
    Hadoop1重新格式化HDFS
    centos6.5之Hadoop1.2.1完全分布式部署安装
    Mybatis延迟加载和查询缓存
    剑指offer面试题7:用两个栈实现队列
    Mybatis输入输出映射
    Mybatis开发Dao
    Mybatis入门程序
    SpringMVC系列之URL匹配问题
    SpringMVC系列之主要组件
    mysql学习笔记(三)
  • 原文地址:https://www.cnblogs.com/kuangbin/p/3025296.html
Copyright © 2011-2022 走看看