zoukankan      html  css  js  c++  java
  • HDU 3652 Bnumber(数位DP)

    B-number

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 1231    Accepted Submission(s): 651


    Problem Description
    A wqb-number, or B-number for short, is a non-negative integer whose decimal form contains the sub- string "13" and can be divided by 13. For example, 130 and 2613 are wqb-numbers, but 143 and 2639 are not. Your task is to calculate how many wqb-numbers from 1 to n for a given integer n.
     
    Input
    Process till EOF. In each line, there is one positive integer n(1 <= n <= 1000000000).
     
    Output
    Print each answer in a single line.
     
    Sample Input
    13 100 200 1000
     
    Sample Output
    1 1 2 2
     
    Author
    wqb0039
     
    Source
     
    Recommend
    lcy
     
     
    比较简单的数位DP,随便搞
    /*
     * HDU 3652 B-number
     * 含有数字13和能够被13整除的数的个数
     * dp[i][j][k][z]:i:处理的数位,j:该数对13取模以后的值,k:是否已经包含13,z结尾的数
     */
    #include <iostream>
    #include <string.h>
    #include <algorithm>
    #include <stdio.h>
    using namespace std;
    int dp[12][15][2][10];
    int bit[12];
    int dfs(int pos,int num,bool t,int e,bool flag)
    {
        if(pos==-1)return t&&(num==0);
        if(!flag && dp[pos][num][t][e]!=-1)
            return dp[pos][num][t][e];
        int end=flag?bit[pos]:9;
        int ans=0;
        for(int i=0;i<=end;i++)
            ans+=dfs(pos-1,(num*10+i)%13,t||(e==1&&i==3),i,flag&&(i==end));
        if(!flag)dp[pos][num][t][e]=ans;
        return ans;
    }
    int calc(int n)
    {
        int pos=0;
        while(n)
        {
            bit[pos++]=n%10;
            n/=10;
        }
        return dfs(pos-1,0,0,0,1);
    }
    int main()
    {
        //freopen("in.txt","r",stdin);
        //freopen("out.txt","w",stdout);
        int n;
        memset(dp,-1,sizeof(dp));
        while(scanf("%d",&n)==1)
        {
            printf("%d\n",calc(n));
        }
        return 0;
    }
    人一我百!人十我万!永不放弃~~~怀着自信的心,去追逐梦想
  • 相关阅读:
    在Wince下使用钩子函数
    WinCE下钩子应用(一)——WinCE 下实时捕获键盘消息
    记录此刻
    常用数列
    百度之星度度熊拼三角
    笛卡尔定理
    Lucas定理
    简单概念
    Unknown Treasure Lucas+中国剩余定理+快速乘
    2017ccpc杭州站 Problem B. Master of Phi
  • 原文地址:https://www.cnblogs.com/kuangbin/p/3052686.html
Copyright © 2011-2022 走看看