zoukankan      html  css  js  c++  java
  • HDU

    Problem Description
    Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

    One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

    For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.
     

    Input
    The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
     

    Output
    For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
     

    Sample Input
    2 5 3 1 2 2 3 4 5 5 1 2 5
     

    Sample Output
    2 4
    #include <iostream>
    #include <cstdio>
    #include <cstdlib>
    #include <cstring>
    #include <string>
    #include <vector>
    #include <algorithm>
    using namespace std;
    
    int pre[1024];
    bool istop[1024];
    
    int Find(int x)
    {
    	int l = x;
    	while (l != pre[l])
    		l = pre[l];
    	while (l != pre[x]){
    		int t = pre[x];
    		pre[x] = l;
    		x = t;
    	}
    	return l;
    }
    
    void join(const int x, const int y)
    {
    	int fx = Find(x);
    	int fy = Find(y);
    	pre[fx] = fy;
    }
    
    int main()
    {
    	int T; cin >> T;
    	while (T--){
    		for (int i = 0; i < 1024; i++)
    			pre[i] = i;
    		memset(istop, false, sizeof(istop));
    		int N, M; cin >> N >> M;
    		while (M--){
    			int x, y; cin >> x >> y;
    			join(x, y);
    		}
    		for (int i = 1; i <= N; i++)
    			istop[Find(i)] = true;
    		int cnt = 0;
    		for (int i = 1; i <= N; i++)
    			if (istop[i])
    				cnt++;
    		cout << cnt << endl;
    	}
    	return 0;
    }


  • 相关阅读:
    香港的困境
    美国的制度
    媒体行业
    张首晟生前最著名演讲:这几句话可以总结人类所有知识
    印度的发展
    中国互联网发展解读
    cnblogs博客使用LaTeX公式
    Stanford CS229 Machine Learning by Andrew Ng
    强化学习在业界的实际应用
    AUC计算方法
  • 原文地址:https://www.cnblogs.com/kunsoft/p/5312743.html
Copyright © 2011-2022 走看看