zoukankan      html  css  js  c++  java
  • POJ 2643 Election map

    POJ 2643 Election

    第一次写博客,想通过写博客记录自己的ACM历程,也想解释下英文题目,写些自己的理解。也可以让自己以后找题目更加方便点嘛。
    Election
    Time Limit: 1000MS Memory Limit: 65536K
    Total Submissions: 4491 Accepted: 2100
    Description

    Canada has a multi-party system of government. Each candidate is generally associated with a party, and the party whose candidates win the most ridings generally forms the government. Some candidates run as independents, meaning they are not associated with any party. Your job is to count the votes for a particular riding and to determine the party with which the winning candidate is associated.
    Input

    The first line of input contains a positive integer n satisfying 2 <= n <= 20, the number of candidates in the riding. n pairs of lines follow: the first line in each pair is the name of the candidate, up to 80 characters; the second line is the name of the party, up to 80 characters, or the word “independent” if the candidate has no party. No candidate name is repeated and no party name is repeated in the input. No lines contain leading or trailing blanks.
    The next line contains a positive integer m <= 10000, and is followed by m lines each indicating the name of a candidate for which a ballot is cast. Any names not in the list of candidates should be ignored.
    Output

    Output consists of a single line containing one of:
    The name of the party with whom the winning candidate is associated, if there is a winning candidate and that candidate is associated with a party.
    The word “independent” if there is a winning candidate and that candidate is not associated with a party.
    The word “tie” if there is no winner; that is, if no candidate receives more votes than every other candidate.
    Sample Input

    3
    Marilyn Manson
    Rhinoceros
    Jane Doe
    Family Coalition
    John Smith
    independent
    6
    John Smith
    Marilyn Manson
    Marilyn Manson
    Jane Doe
    John Smith
    Marilyn Manson
    Sample Output

    Rhinoceros
    Source

    Waterloo local 1999.06.19
    这道题的大意是先输入几个参加选举的人员的名字与党派(先名字后党派),然后再输入的是投票,每一行的名字代表有人投了这个人一票。
    最后再输出得票最多的人的党派,注无党派就是independent,如果同时有几个人得票最多的话,就输出tie。

    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<string>
    #include<map> 
    using namespace std;
    int main()
    {
        int t;
        cin >> t;
        getchar();
        map<string,string>mm;
        while(t--)//输入参与选举的人与党派
        {
            char s1[100],s2[100];
            gets(s1);
            gets(s2);
            mm[s1] = s2;
        }   
        int n;
        cin >> n;
        getchar();
        map<string,int>mn;
        while(n--)//输入得到选举票的人
        {
            char s3[100];
            gets(s3);
            mn[s3]++;
        } 
        string str;
        int a=0,flag=0;
        for(map<string,int>::iterator it=mn.begin();it!=mn.end();it++)//找得票最多的人
        {
            if(it->second>=a)
            {
                a = it->second;
                str = it->first;
            }
        }
        for(map<string,int>::iterator it=mn.begin();it!=mn.end();it++)//判断得票最多的有几个人
        {
            if(it->second==mn[str])
            {
                flag++;
            }
        }
        if(flag>=2)//如果有多个人就输出tie
           printf("tie\n");
        else cout << mm[str] << endl;//否则输出其党派
        return 0;
    } 
    彼时当年少,莫负好时光。
  • 相关阅读:
    CentOS6.5(1)----设置静态IP并禁用IPV6
    CentOS7运维管理笔记(12)----修改主机名
    重温C语言(1)----计算算术表达式的值
    C++学习笔记(9)----关于变量和数组大小的一道容易出错的面试题
    MySQL数据库(13)----忘记root用户密码解决方案【转载】
    C++学习笔记(8)----C++类的大小
    C++学习笔记(7)----类的数组中构造函数和析构函数的调用顺序
    C++学习笔记(6)----基类和派生类的构造函数和析构函数的执行顺序
    switch的参数类型
    windows下双击可运行的Java软件打包方案(转)
  • 原文地址:https://www.cnblogs.com/l609929321/p/6545106.html
Copyright © 2011-2022 走看看