zoukankan      html  css  js  c++  java
  • poj 3250 Bad Hair Day (单调栈)

    Bad Hair Day
    Time Limit: 2000MS   Memory Limit: 65536K
    Total Submissions: 14883   Accepted: 4940

    Description

    Some of Farmer John's N cows (1 ≤ N ≤ 80,000) are having a bad hair day! Since each cow is self-conscious about her messy hairstyle, FJ wants to count the number of other cows that can see the top of other cows' heads.

    Each cow i has a specified height hi (1 ≤ h≤ 1,000,000,000) and is standing in a line of cows all facing east (to the right in our diagrams). Therefore, cow i can see the tops of the heads of cows in front of her (namely cows i+1, i+2, and so on), for as long as these cows are strictly shorter than cow i.

    Consider this example:

            =
    =       =
    =   -   =         Cows facing right -->
    =   =   =
    = - = = =
    = = = = = =
    1 2 3 4 5 6 

    Cow#1 can see the hairstyle of cows #2, 3, 4
    Cow#2 can see no cow's hairstyle
    Cow#3 can see the hairstyle of cow #4
    Cow#4 can see no cow's hairstyle
    Cow#5 can see the hairstyle of cow 6
    Cow#6 can see no cows at all!

    Let ci denote the number of cows whose hairstyle is visible from cow i; please compute the sum of c1 through cN.For this example, the desired is answer 3 + 0 + 1 + 0 + 1 + 0 = 5.

    Input

    Line 1: The number of cows, N
    Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i.

    Output

    Line 1: A single integer that is the sum of c1 through cN.

    Sample Input

    6
    10
    3
    7
    4
    12
    2

    Sample Output

    5

    单调栈的入门题:单调栈就是维护一个栈,栈中的元素都保持着单调递增或递减的顺序。

    题目意思:有n仅仅牛站在一排,给出队伍中每仅仅牛的高度。每仅仅牛仅仅能看到它右边比它矮的牛。求全部的牛能看到的牛数之和。

    当我们新增加一个高度值时,假设栈中存在元素小于新增加的高度值。那这个牛肯定看不见这个高度的牛,就把这个元素弹栈。每次增加新元素,并运行完弹出操作后,栈中元素个数便是能够看见这个牛的“牛数”。


    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <stack>
    typedef long long ll;
    using namespace std;
    int main()
    {
        int n;
        ll heigh,ans;
        stack<ll>s;
        while(scanf("%d",&n)!=EOF)
        {
            ans=0;
            cin>>heigh;
            s.push(heigh);//入栈
            for(int i=1;i<n;i++)
            {
                cin>>heigh;
                while(!s.empty()&&s.top()<=heigh) //比較栈顶元素和新增加元素的关系
                {
                    s.pop();
                }
                ans+=s.size();
                s.push(heigh);
            }
            cout<<ans<<endl;
            while(!s.empty()) s.pop();//空栈
        }
        return 0;
    }
    



  • 相关阅读:
    golang mod 导包
    grpc client 报错: code = Unimplemented desc = method *** not implemented
    golang读取email
    docker 使用
    在word中批量更改Mathtype公式的格式
    word中插入myth type公式行距变大的问题
    word中编辑论文公式对齐问题
    向别人学习
    机器学习 博文汇总
    matlab中如何用rand产生相同的随机数
  • 原文地址:https://www.cnblogs.com/lcchuguo/p/5047390.html
Copyright © 2011-2022 走看看