zoukankan      html  css  js  c++  java
  • Censoring【KMP算法+堆栈模拟】

    Censoring

    传送门:链接   来源:UPC8203

    题目描述

    Farmer John has purchased a subscription to Good Hooveskeeping magazine for his cows, so they have plenty of material to read while waiting around in the barn during milking sessions. Unfortunately, the latest issue contains a rather inappropriate article on how to cook the perfect steak, which FJ would rather his cows not see (clearly, the magazine is in need of better editorial oversight).

    FJ has taken all of the text from the magazine to create the string S of length at most 10^6 characters. From this, he would like to remove occurrences of a substring T to censor the inappropriate content. To do this, Farmer John finds the _first_ occurrence of T in S and deletes it. He then repeats the process again, deleting the first occurrence of T again, continuing until there are no more occurrences of T in S. Note that the deletion of one occurrence might create a new occurrence of T that didn't exist before.

    Please help FJ determine the final contents of S after censoring is complete.

    输入

    The first line will contain S. The second line will contain T. The length of T will be at most that of S, and all characters of S and T will be lower-case alphabet characters (in the range a..z). 

    输出

    The string S after all deletions are complete. It is guaranteed that S will not become empty during the deletion process. 

    样例输入

    whatthemomooofun
    moo
    

    样例输出

    whatthefun
    

    题目大意:

       给出a,p两个字符串从a中消去所有的p,直到不能消去为止。

    思路分析:

    尝试了三种做法:

    1、直接vector删除,结果TLE。

    2、Next[]数组+vector删除,结果TLE(应该是哪里bug死循环了,现在也没找到原因,估计是kmp的代码不行)。

    3、看了别人的题解:传送门,发现可以用堆栈模拟来做。(下面讲的就是这种方法)

    之前一想到删除操作第一反应就是vector,看来以后也要考虑堆栈了,用vector应该也行。

    看上面博客写的kmp代码和我的不太一样,顺便学习了一下他的代码。

    AC代码:

    #include<bits/stdc++.h>
    using namespace std;
    typedef long long LL;
    const LL MAX=1e6;
    LL Next[MAX+5],flag[MAX+5];
    char Stack[MAX+5];
    void getNext(string p,LL lp,LL Next[]){
        LL k=0;
        for(LL i=1;i<lp;i++){
            while(k&&p[i]!=p[k]) k=Next[k];
            if(p[i]==p[k]) k++;
            Next[i+1]=k;
        }
    }
    void kmp(string a,string p,LL la,LL lp){
        LL j=0,top=0;
        for(LL i=0;i<la;i++){
            Stack[++top]=a[i];
            while(j&&a[i]!=p[j]) j=Next[j];
            if(a[i]==p[j]) j++;
            if(j==lp) top-=lp,j=flag[top];
            flag[top]=j;
        }
        for(int i=1;i<=top;i++){ ///堆栈中剩余的都是没被删除的,直接输出就行了。
            cout<<Stack[i];
        }
        cout<<endl;
    }
    int main()
    {
        string a,p;
        cin>>a>>p;
        LL la=a.size(),lp=p.size();
        getNext(p,lp,Next);
        kmp(a,p,la,lp);
        return 0;
    }
    
  • 相关阅读:
    我们是怎么管理QQ群的
    2014年10月【下】-前端开发半月刊
    我们一般的前端开发流程
    没有素描色彩基础适合学习UI吗,如果可以,该怎么学?
    豪情-关于生活工作学习之感悟-第一篇
    网页插件学javascript还是jquery好啊?
    我们平时是怎么写html和css的?
    2014年10月【上】-前端开发半月刊
    2014年9月-前端开发月刊
    固定滚动菜单
  • 原文地址:https://www.cnblogs.com/ldu-xingjiahui/p/12407412.html
Copyright © 2011-2022 走看看