zoukankan      html  css  js  c++  java
  • Windows Message Queue(容器之queue)

    Description

    Message queue is the basic fundamental of windows system. For each process, the system maintains a message queue. If something happens to this process, such as mouse click, text change, the system will add a message to the queue. Meanwhile, the process will do a loop for getting message from the queue according to the priority value if it is not empty. Note that the less priority value means the higher priority. In this problem, you are asked to simulate the message queue for putting messages to and getting message from the message queue.

    Input

    There's only one test case in the input. Each line is a command, "GET" or "PUT", which means getting message or putting message. If the command is "PUT", there're one string means the message name and two integer means the parameter and priority followed by. There will be at most 60000 command. Note that one message can appear twice or more and if two messages have the same priority, the one comes first will be processed first.(i.e., FIFO for the same priority.) Process to the end-of-file.

    Output

    For each "GET" command, output the command getting from the message queue with the name and parameter in one line. If there's no message in the queue, output "EMPTY QUEUE!". There's no output for "PUT" command.

    Sample Input

    GET
    PUT msg1 10 5
    PUT msg2 10 4
    GET
    GET
    GET
    

    Sample Output

    EMPTY QUEUE!
    msg2 10
    msg1 10
    EMPTY QUEUE!
    

    #include <iostream>
    #include <string>
    #include <queue>
    using namespace std;
    struct node
    {string a;
    int b,c,d;
    bool friend operator<(node n1,node n2)
    {
     if(n1.c==n2.c)return n1.d>n2.d;
     return n1.c >n2.c;
    }
    }s;

    int main()
    { priority_queue<node>q;
    string a1;
    int k=1;
    while(cin>>a1)
    {if(a1[0]=='G')
    {if(!q.empty())
    {s=q.top();
    q.pop();
    cout<<s.a<<" "<<s.b<<endl;}
    else cout<<"EMPTY QUEUE!"<<endl;

    }
    else {cin>>s.a>>s.b>>s.c;
    s.d=k++;
    q.push(s);}
    }
    return 0;}


  • 相关阅读:
    谈谈我的经历--【产品设计中遇到的坑0】系列文章的序
    2017.02.04,读书,2017第二本《把时间当作朋友》读书笔记
    读书《重生,七年就是一辈子》
    好剧推荐:This is us
    直播预告:产品设计中不得不知的事情
    高德地图事件与插件绑定
    高德地图基础
    es6 Iterator和for...of循环
    class与class的继承
    JS保留两位小数的几种方法
  • 原文地址:https://www.cnblogs.com/lengxia/p/4387810.html
Copyright © 2011-2022 走看看