zoukankan      html  css  js  c++  java
  • Tree Recovery(过遍历确定二叉树结构)

    Description

    Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomly looking binary trees with capital letters in the nodes. 
    This is an example of one of her creations: 
                                                   D
    
                                                  / 
    
                                                 /   
    
                                                B     E
    
                                               /      
    
                                              /        
    
                                             A     C     G
    
                                                        /
    
                                                       /
    
                                                      F
    
    

    To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree). For the tree drawn above the preorder traversal is DBACEGF and the inorder traversal is ABCDEFG. 
    She thought that such a pair of strings would give enough information to reconstruct the tree later (but she never tried it). 

    Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree. 
    However, doing the reconstruction by hand, soon turned out to be tedious. 
    So now she asks you to write a program that does the job for her! 

    Input

    The input will contain one or more test cases. 
    Each test case consists of one line containing two strings preord and inord, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters. (Thus they are not longer than 26 characters.) 
    Input is terminated by end of file. 

    Output

    For each test case, recover Valentine's binary tree and print one line containing the tree's postorder traversal (left subtree, right subtree, root).

    Sample Input

    DBACEGF ABCDEFG
    BCAD CBAD
    

    Sample Output

    ACBFGED
    CDAB
    



    #include <iostream>
    #include <cstring>
    using namespace std;


    char a1[30],a2[30];
    int c, l1,l2;
    void Tree(int i,int j)
    {
        int k;
        char root;
        if (i > j)
        return ;
        root = a1[c++];
        for(k=i;k<=j;k++)
            if(root == a2[k])
            break;
        Tree(i,k-1);
        Tree(k+1,j);
        printf("%c",root);


    }
    int main()
    {
        while(scanf("%s %s",a1,a2)!=EOF)
        {
            getchar();
            l2 = strlen(a2);
            c = 0;
            Tree(0,l2-1);
            printf(" ");


        }
    return 0;}
  • 相关阅读:
    VS中添加搜索路径和链接库的方法
    hive多分隔符支持
    shell 遍历目录下的所有文件
    使用ansible控制Hadoop服务的启动和停止【转】
    Shell中的括号有其特殊的用法
    shell中括号[]的特殊用法 linux if多条件判断
    Linux中rz和sz命令用法详解
    vim 去掉自动注释和自动回车
    ping判断局域网ip使用情况
    shell判断有效日期
  • 原文地址:https://www.cnblogs.com/lengxia/p/4387813.html
Copyright © 2011-2022 走看看