zoukankan      html  css  js  c++  java
  • uva1160

    X-Plosives

    A secret service developed a new kind of explosive that attain its volatile property only when a specific association of products occurs. Each product is a mix of two different simple compounds, to which we call a binding pair. If N>2, then mixing N different binding pairs containing N simple compounds creates a powerful explosiveFor example, the binding pairs A+B, B+C, A+C (three pairs, three compounds) result in an explosive, while A+B, B+C, A+D (three pairs, four compounds) does not.

     

    You are not a secret agent but only a guy in a delivery agency with one dangerous problem: receive binding pairs in sequential order and place them in a cargo ship. However, you must avoid placing in the same room an explosive association. So, after placing a set of pairs, if you receive one pair that might produce an explosion with some of the pairs already in stock, you must refuse it, otherwise, you must accept it.

     

    An example. Let’s assume you receive the following sequence: A+B, G+B, D+F, A+E, E+G, F+H. You would accept the first four pairs but then refuse E+G since it would be possible to make the following explosive with the previous pairs: A+B, G+B, A+E, E+G (4 pairs with 4 simple compounds). Finally, you would accept the last pair, F+H.

     

    Compute the number of refusals given a sequence of binding pairs.

     

    Input

    The input will contain several test cases, each of them as described below. Consecutive test cases are separated by a single blank line.

    Instead of letters we will use integers to represent compounds. The input contains several lines. Each line (except the last) consists of two integers (each integer lies between 0 and 105) separated by a single space, representing a binding pair. The input ends in a line with the number –1. You may assume that no repeated binding pairs appears in the input.

     

    Output

    For each test case, a single line with the number of refusals.

     

    Sample Input

    1 2

    3 4

    3 5

    3 1

    2 3

    4 1

    2 6

    6 5

    -1

     

    Sample Output

    3




    #include <iostream>
    #include <stdio.h>
    using namespace std;
    const int maxn=100000+10;
    int p[maxn];
    int find(int x){return p[x]!=x?p[x]=find(p[x]):x;}
    int main()
    {int x,y,i;
    while(scanf("%d",&x)==1)
    {for(i=0;i<maxn;i++)p[i]=i;
    int re=0;
    while(x!=-1)
    {cin>>y;
    x=find(x);y=find(y);
    if(x==y)re++;
    else p[x]=y;
    cin>>x;


    }
    cout<<re<<endl;
    }


    return 0;
    }


  • 相关阅读:
    Zjnu Stadium(hdu3047带权并查集)
    cocos2d-x结合cocosbuilder,不同屏幕适配小结
    分布式爬虫系统设计、实现与实战:爬取京东、苏宁易购全网手机商品数据+MySQL、HBase存储
    Generating RSA keys in PKCS#1 format in Java--转
    nodejs安装node-rsa遇到的问题及解决
    spring-redis-data的一个坑
    node-rsa加密,java解密调试
    MySQL 四种事务隔离级别详解及对比--转
    从实际案例聊聊Java应用的GC优化--转
    动态可缓存的内容管理系统(CMS)
  • 原文地址:https://www.cnblogs.com/lengxia/p/4387823.html
Copyright © 2011-2022 走看看