zoukankan      html  css  js  c++  java
  • I Think I Need a Houseboat(1.3.1)

    Description

    Fred Mapper is considering purchasing some land in Louisiana to build his house on. In the process of investigating the land, he learned that the state of Louisiana is actually shrinking by 50 square miles each year, due to erosion caused by the Mississippi River. Since Fred is hoping to live in this house the rest of his life, he needs to know if his land is going to be lost to erosion.

    After doing more research, Fred has learned that the land that is being lost forms a semicircle. This semicircle is part of a circle centered at (0,0), with the line that bisects the circle being the X axis. Locations below the X axis are in the water. The semicircle has an area of 0 at the beginning of year 1. (Semicircle illustrated in the Figure.)

    Input

    The first line of input will be a positive integer indicating how many data sets will be included (N). Each of the next N lines will contain the X and Y Cartesian coordinates of the land Fred is considering. These will be floating point numbers measured in miles. The Y coordinate will be non-negative. (0,0) will not be given.

    Output

    For each data set, a single line of output should appear. This line should take the form of: “Property N: This property will begin eroding in year Z.” Where N is the data set (counting from 1), and Z is the first year (start from 1) this property will be within the semicircle AT THE END OF YEAR Z. Z must be an integer. After the last data set, this should print out “END OF OUTPUT.”

    Sample Input

    2
    1.0 1.0
    25.0 0.0

    Sample Output

    Property 1: This property will begin eroding in year 1.
    Property 2: This property will begin eroding in year 20.
    END OF OUTPUT.
    
    
    
    #include <iostream>
    #include<cmath>
    using namespace std;
    int main()
    {int t,i;
    cin>>t;
    for(i=1;i<t+1;i++)
    {double a1,a2;
    int n;
    cin>>a1>>a2;
    a1=(a1*a1+a2*a2)*3.14/100;
    
    
    cout<<"Property "<<i<<": "<<"This property will begin eroding in year "<<ceil(a1)<<"."<<endl;
    }
    cout<<"END OF OUTPUT."<<endl;
    return 0;}

  • 相关阅读:
    你最喜欢的程序员漫画
    编程名言名句
    查看一个数是不是2的n次方
    程序员需要有多懒 ?- cocos2d-x 数学函数、常用宏粗整理
    C++中string、int、char之间转换
    cocos2d-x 中使用 srand((unsigned)time(NULL))重新设置一个随机种子
    ASP.NET MVC SignalR 配合VUE
    VS Visual Studio光标无法自动到行尾,点哪里就在哪里解决办法
    .NET Core Entity Framework 代码优先配置
    Image Bitmap转MemoryStream后,上传遇到问题,报Index异常
  • 原文地址:https://www.cnblogs.com/lengxia/p/4387855.html
Copyright © 2011-2022 走看看