zoukankan      html  css  js  c++  java
  • Children’s Queue

    http://acm.hdu.edu.cn/diy/contest_showproblem.php?pid=1001&cid=22706




    Problem Description

    There are many students in PHT School. One day, the headmaster whose name is PigHeader wanted all students stand in a line. He prescribed that girl can not be in single. In other words, either no girl in the queue or more than one girl stands side by side. The case n=4 (n is the number of children) is like
    FFFF, FFFM, MFFF, FFMM, MFFM, MMFF, MMMM
    Here F stands for a girl and M stands for a boy. The total number of queue satisfied the headmaster’s needs is 7. Can you make a program to find the total number of queue with n children?

    Input

    There are multiple cases in this problem and ended by the EOF. In each case, there is only one integer n means the number of children (1<=n<=1000)

    Output

    For each test case, there is only one integer means the number of queue satisfied the headmaster’s needs.

    Sample Input

    1
    2
    3
    

    Sample Output

    1
    2
    4
    

    Author

    SmallBeer (CML)

    Source

    杭电ACM集训队训练赛(VIII)


    #include<iostream> 
    using namespace std;
    int a[1001][300];
    int main()
    {    int i,j,n,k;  
      a[1][0] = 1;   
      a[2][0] = 2;   
      a[3][0] = 4;   
      a[4][0] = 7;    
      for(i = 5;i < 1001;i++)    
      {          
          k = 0;          
          for(j = 0;j < 300;j++)          
          {                
              a[i][j] = a[i-1][j] + a[i-2][j] + a[i-4][j] + k;                
              k = a[i][j] / 10;                
              a[i][j] %= 10;          
    }    
    }    
      while(cin >> n)   
      {             
          i = 299;              
          while(i >= 0 && !a[n][i])                      
              i--;              
          while(i >= 0)                      
              cout << a[n][i--];              
          cout << endl;    }    
      return 0;}

  • 相关阅读:
    ibatis 批量更新(一)
    eclipse tomcat路径更改后启动报错
    xftp Initialize Flexnet Service failed / Error code: 50003
    百度网盘 文件名中(文件)含有敏感词
    一人之下第二季百度云高清下载
    React Native Mac配置指南
    Androd自己定义控件(三)飞翔的小火箭
    关于职位规划
    SSH框架之Struts(3)——Struts的执行流程之核心方法
    HDU 4891 The Great Pan (字符串处理)
  • 原文地址:https://www.cnblogs.com/lengxia/p/4387881.html
Copyright © 2011-2022 走看看