zoukankan      html  css  js  c++  java
  • HDU 1070 Milk(水题)

    题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1070

    Milk

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 10484    Accepted Submission(s): 2497


    Problem Description
    Ignatius drinks milk everyday, now he is in the supermarket and he wants to choose a bottle of milk. There are many kinds of milk in the supermarket, so Ignatius wants to know which kind of milk is the cheapest.

    Here are some rules:
    1. Ignatius will never drink the milk which is produced 6 days ago or earlier. That means if the milk is produced 2005-1-1, Ignatius will never drink this bottle after 2005-1-6(inclusive).
    2. Ignatius drinks 200mL milk everyday.
    3. If the milk left in the bottle is less than 200mL, Ignatius will throw it away.
    4. All the milk in the supermarket is just produced today.

    Note that Ignatius only wants to buy one bottle of milk, so if the volumn of a bottle is smaller than 200mL, you should ignore it.
    Given some information of milk, your task is to tell Ignatius which milk is the cheapest.
     
    Input
    The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
    Each test case starts with a single integer N(1<=N<=100) which is the number of kinds of milk. Then N lines follow, each line contains a string S(the length will at most 100 characters) which indicate the brand of milk, then two integers for the brand: P(Yuan) which is the price of a bottle, V(mL) which is the volume of a bottle.
     
    Output
    For each test case, you should output the brand of the milk which is the cheapest. If there are more than one cheapest brand, you should output the one which has the largest volume.
     
    Sample Input
    2 2 Yili 10 500 Mengniu 20 1000 4 Yili 10 500 Mengniu 20 1000 Guangming 1 199 Yanpai 40 10000
     
    Sample Output
    Mengniu Mengniu
    Hint
    In the first case, milk Yili can be drunk for 2 days, it costs 10 Yuan. Milk Mengniu can be drunk for 5 days, it costs 20 Yuan. So Mengniu is the cheapest.In the second case, milk Guangming should be ignored. Milk Yanpai can be drunk for 5 days, but it costs 40 Yuan. So Mengniu is the cheapest.
     
    Author
    Ignatius.L
     
     
    水水更健康。。。。这里注意下,牛奶最多只能喝5天,少于200ml的牛奶不算,如果最便宜的牛奶不止一种,那么得选容量最大的一个。。注意就算是牛奶容量大于5天能喝掉的量,也就是1000ml,也不能直接把多于1000ml的部分忽略。。
     
     
     By LFENG
     
    #include<cstdio>
    #include<algorithm>
    #include<cstring>
    using namespace std;
    struct milk
    {
        
    int ml;
        
    int day;
        
    char name[105];
        
    double price;
    }mi[
    105];
    int n,m;
    bool cmp(milk a,milk b)
    {
        
    if(a.price!=b.price)return a.price<b.price;
        
    else if(a.price==b.price)return a.ml>b.ml;
    }
    void getdata()
    {
        
    int i,a;
        
    char s[105];
        scanf(
    "%d",&n);
        
    for(i=0,m=0;i<n;i++)
        {
            scanf(
    "%s %d %d",mi[m].name,&a,&mi[m].ml);
            
    if(mi[m].ml<200)continue;
            mi[m].day=mi[m].ml/
    200;
            
    if(mi[m].day>5)mi[m].day=5;
            mi[m].price=a/mi[m].day;
            m++;
        }
        sort(mi,mi+m,cmp);
    }
    int main()
    {
        
    int t;
        scanf(
    "%d",&t);
        getchar();
        
    while(t--)
        {
            getdata();
            printf(
    "%s\n",mi[0].name);
        }
        
    return 0;
    }
  • 相关阅读:
    手机屏幕边缘发黄(抢救处理)
    Error parsing HTTP request header 错误解决方法
    SpringBoot项目部署到外部Tomcat重复启动的解决方法
    手机文件管理中网络邻居的使用方法
    解决Tomcat启动过程中报错org.springframework.jmx.export.UnableToRegisterMBeanException
    SpringBoot打成war包后Tomcat无法访问静态资源问题
    Springboot如何使用外部tomcat容器
    Maven打包并入本地jar包
    Excel小技巧之VLOOKUP()使用简单说明
    java.io.IOException: Server returned HTTP response code: 403 for URL
  • 原文地址:https://www.cnblogs.com/lfeng/p/3101151.html
Copyright © 2011-2022 走看看