zoukankan      html  css  js  c++  java
  • poj_1274The Perfect Stall

    The Perfect Stall
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 15823   Accepted: 7234

    Description

    Farmer John completed his new barn just last week, complete with all the latest milking technology. Unfortunately, due to engineering problems, all the stalls in the new barn are different. For the first week, Farmer John randomly assigned cows to stalls, but it quickly became clear that any given cow was only willing to produce milk in certain stalls. For the last week, Farmer John has been collecting data on which cows are willing to produce milk in which stalls. A stall may be only assigned to one cow, and, of course, a cow may be only assigned to one stall. 
    Given the preferences of the cows, compute the maximum number of milk-producing assignments of cows to stalls that is possible. 

    Input

    The input includes several cases. For each case, the first line contains two integers, N (0 <= N <= 200) and M (0 <= M <= 200). N is the number of cows that Farmer John has and M is the number of stalls in the new barn. Each of the following N lines corresponds to a single cow. The first integer (Si) on the line is the number of stalls that the cow is willing to produce milk in (0 <= Si <= M). The subsequent Si integers on that line are the stalls in which that cow is willing to produce milk. The stall numbers will be integers in the range (1..M), and no stall will be listed twice for a given cow.

    Output

    For each case, output a single line with a single integer, the maximum number of milk-producing stall assignments that can be made.

    Sample Input

    5 5
    2 2 5
    3 2 3 4
    2 1 5
    3 1 2 5
    1 2 
    

    Sample Output

    4

    添加起点和终点。。。

    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<map>
    #include<cmath>
    #include<vector>
    #include<algorithm>
    #include<set>
    #include<string>
    #include<queue>
    #include <stack>
    using namespace std;
    #pragma warning(disable : 4996)
    const int MAXN = 205 * 2;
    const int INF = 0x7FFFFFFF;
    int flow[MAXN][MAXN], cap[MAXN][MAXN];
    int maxflow, n, m;
    
    void EKarp(int s, int e)
    {
    	queue<int>Q;
    	int u, v, a[MAXN], father[MAXN];
    	maxflow = 0;
    	memset(flow, 0, sizeof(flow));
    	while (true)
    	{
    		memset(a, 0, sizeof(a));
    		a[s] = INF;
    		Q.push(s);
    		while (!Q.empty())//BFS找增广路
    		{
    			int u = Q.front();
    			Q.pop();
    			for (v = s; v <= e; v++)
    			{
    				if(a[v] == 0 && cap[u][v] > flow[u][v])//找到新节点v
    				{
    					father[v] = u;//记录v的父亲,并加入FIFO队列
    					Q.push(v);
    					a[v] = min(a[u], cap[u][v] - flow[u][v]);//s-v路径上的最小残量
    				}
    			}
    		}
    		if(a[e] == 0)//找不到,则当前流已经是最大流
    		{
    			break;
    		}
    		for (u = e; u != s; u = father[u])//从汇点往回走
    		{
    			flow[father[u]][u] += a[e];//更新正向流量
    			flow[u][father[u]] -= a[e];//更新反向流量
    		}
    		maxflow += a[e];//更新从s流出的总流量
    	}
    }
    
    int main()
    {
    	freopen("in.txt", "r", stdin);
    	int w, num;
    	while(scanf("%d %d", &n, &m) != EOF)
    	{
    		memset(cap, 0, sizeof(cap));
    		for (int i = 1; i <= n; i++)
    		{
    			scanf("%d", &num);
    			while (num--)
    			{
    				scanf("%d", &w);
    				cap[m + i][w] = 1;
    			}
    		}
    		for (int i = m + 1; i <= m + n; i++)
    		{
    			cap[0][i] = 1;
    		}
    		for (int i = 1; i <= m; i++)
    		{
    			cap[i][m + n + 1] = 1;
    		}
    
    		EKarp(0, m + n + 1);
    		printf("%d\n", maxflow);
    	}
    	return 0;
    }



  • 相关阅读:
    android studio 开发环境配置
    解决 php-cgi 启动时提示缺少 msvcr110.dll 的问题
    PHP5.5 + IIS + Win7的配置
    PHP版本VC6和VC9、Non Thread Safe和Thread Safe的区别
    [6]Telerik TreeView 复选框
    详解.NET IL代码(一)
    第三章 续:时间控件(TimePicker)
    第二章 时间控件(DateTime Picker)
    jquery常用方法
    RESTClient
  • 原文地址:https://www.cnblogs.com/lgh1992314/p/5834996.html
Copyright © 2011-2022 走看看