zoukankan      html  css  js  c++  java
  • hdoj_3476Cyclic Nacklace

    Cyclic Nacklace

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 1694    Accepted Submission(s): 736


    Problem Description
    CC always becomes very depressed at the end of this month, he has checked his credit card yesterday, without any surprise, there are only 99.9 yuan left. he is too distressed and thinking about how to tide over the last days. Being inspired by the entrepreneurial spirit of "HDU CakeMan", he wants to sell some little things to make money. Of course, this is not an easy task.

    As Christmas is around the corner, Boys are busy in choosing christmas presents to send to their girlfriends. It is believed that chain bracelet is a good choice. However, Things are not always so simple, as is known to everyone, girl's fond of the colorful decoration to make bracelet appears vivid and lively, meanwhile they want to display their mature side as college students. after CC understands the girls demands, he intends to sell the chain bracelet called CharmBracelet. The CharmBracelet is made up with colorful pearls to show girls' lively, and the most important thing is that it must be connected by a cyclic chain which means the color of pearls are cyclic connected from the left to right. And the cyclic count must be more than one. If you connect the leftmost pearl and the rightmost pearl of such chain, you can make a CharmBracelet. Just like the pictrue below, this CharmBracelet's cycle is 9 and its cyclic count is 2:

    Now CC has brought in some ordinary bracelet chains, he wants to buy minimum number of pearls to make CharmBracelets so that he can save more money. but when remaking the bracelet, he can only add color pearls to the left end and right end of the chain, that is to say, adding to the middle is forbidden.
    CC is satisfied with his ideas and ask you for help.
     

    Input
    The first line of the input is a single integer T ( 0 < T <= 100 ) which means the number of test cases.
    Each test case contains only one line describe the original ordinary chain to be remade. Each character in the string stands for one pearl and there are 26 kinds of pearls being described by 'a' ~'z' characters. The length of the string Len: ( 3 <= Len <= 100000 ).
     

    Output
    For each case, you are required to output the minimum count of pearls added to make a CharmBracelet.
     

    Sample Input
    3 aaa abca abcde
     

    Sample Output
    0 2 5
     
    #include<iostream>
    #include<cstdio>
    #include<cstring>
    using namespace std;
    #pragma warning(disable : 4996)
    int len_p;
    const int MAXN = 100005;
    char pat[MAXN];
    int Next[MAXN];
    void get_next()
    {
    	Next[1] = 0;
    	int i, j = 0;
    	for(i = 2; i <= len_p; i++)
    	{
    		while(j > 0 && pat[j+1] != pat[i])
    		{
    			j = Next[j];
    		}
    		if(pat[j+1] == pat[i])
    		{
    			j += 1;
    		}
    		Next[i] = j;
    	}
    }
    
    
    int main()
    {
    	freopen("in.txt", "r", stdin);
    	int t, ans;
    	scanf("%d", &t);
    	while(t--)
    	{
    		ans = 0;
    		scanf("%s", pat + 1);
    		len_p = strlen(pat + 1);
    		get_next();
    		ans = len_p - Next[len_p];
    		if(ans == len_p)
    		{
    			printf("%d\n", ans);
    		}
    		else
    		{
    			for (int i = 0; i < MAXN; i++)
    			{
    				if((len_p + i) % ans == 0)
    				{
    					printf("%d\n", i);
    					break;
    				}
    			}
    		}
    	}
    }



  • 相关阅读:
    在Win7 64位电脑上安装Sql Server 2008 R2 Express
    尝试u盘重装系统
    摘自《北方人》
    编写一个换算GPA 的Application 程序,对于学生学习的每门课程,都输入两个整数:考试成绩和学分,考试成绩按如下公式换算: 85~100:4 75~84:3 60~74:2 45~59:1 44以下:0 GPA等于换算后每门课的成绩的学分加权平均值
    java编程题
    生成器并发处理其实就是函数的切换
    生成器与文档结合
    生成器函数
    生成器表达式、三元表达式、列表解析
    迭代,列表,字典,文件迭代
  • 原文地址:https://www.cnblogs.com/lgh1992314/p/5835019.html
Copyright © 2011-2022 走看看