zoukankan      html  css  js  c++  java
  • 03-3. Tree Traversals Again (PAT)

    An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.

    Figure 1

    Input Specification:

    Each input file contains one test case. For each case, the first line contains a positive integer N (<=30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.

    Output Specification:

    For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

    Sample Input:

    6
    Push 1
    Push 2
    Push 3
    Pop
    Pop
    Push 4
    Pop
    Pop
    Push 5
    Push 6
    Pop
    Pop

    Sample Output:

    3 4 2 6 5 1

    题意解析:入栈顺序即为先序遍历的顺序,出栈顺序即为中序遍历的顺序

    解题思路:

        1.根据入栈出栈顺序,建立先序遍历数组与中序遍历数组。

        2.取先序序列中的第一个元素,该元素为根结点

        3.根据根结点在中序序列中查找根结点的位置,从而得到该树左子树结点个数(L)与右子树的结点个数(R)

        4.在后序序列数组中,第0到第L个元素为左子树,第L+1到第L+R个元素为右子树,最后一个元素为根结点

    #include <iostream>
    #include <string>
    #include <stack>
    using namespace std;
    
    #define MAXSIZE 30
    
    int preOrder[MAXSIZE];
    int inOrder[MAXSIZE];
    int postOrder[MAXSIZE];
    
    void Solve(int preL, int inL, int postL, int n);
    
    int main()
    {
        for (int i = 0; i < MAXSIZE; i++)    //初始化数组
        {
            preOrder[i] = 0;
            inOrder[i] = 0;
            postOrder[i] = 0;
        }
        stack<int> inputStack;
        int nodeNum;
        cin >> nodeNum;
        int i, data;
        int preIndex = 0, inIndex = 0, postIndex = 0;
        string str;
        for (i = 0; i < 2 * nodeNum; i++)
        {
            cin >> str;
            if (str == "Push")
            {
                cin >> data;
                preOrder[preIndex++] = data;
                inputStack.push(data);
            }
            else if (str == "Pop")
            {
                inOrder[inIndex++] = inputStack.top();
                inputStack.pop();
            }
        }
        Solve(0, 0, 0, nodeNum);
        for (int i = 0; i < nodeNum; i++)
        {
            if ( i == nodeNum - 1 )
            {
                cout << postOrder[i] << endl;
            }
            else
            {
                cout << postOrder[i] << ' ';
            }
        }
    }
    
    void Solve(int preL, int inL, int postL, int n)
    {
        if ( n == 0 )
        {
            return;
        }
        if ( n == 1 )
        {
            postOrder[postL] = preOrder[preL];
            return;
        }
        int root = preOrder[preL];
        postOrder[postL + n - 1] = root;
        int L, R;
        int i;
        for (i = 0; i < n; i++)
        {
            if ( inOrder[inL + i] == root )
            {
                break;
            }
        }
        L = i;    //左子树结点个数
        R = n - L - 1;    //右子树结点个数
        Solve(preL + 1, inL, postL, L);
        Solve(preL + L + 1, inL + L + 1, postL + L, R);
    }
  • 相关阅读:
    ASP.NET MVC4 Web 编程第三章
    ASP.NET MVC4 Web 编程第二章
    2020.08.25日
    ASP.NET MVC4 Web 编程第一章
    .net你必须知道的事儿 2.2
    .net你必须知道的事儿 2.1
    资本论
    Cent os mysql主从同步问题
    apache启动脚本
    zentao(禅道)迁移
  • 原文地址:https://www.cnblogs.com/liangchao/p/4281458.html
Copyright © 2011-2022 走看看