zoukankan      html  css  js  c++  java
  • Uva 152 Tree's a Crowd

    Tree's a Crowd 

    Time limit: 3.000 seconds

    Dr William Larch, noted plant psychologist and inventor of the phrase ``Think like a tree--Think Fig'' has invented a new classification system for trees. This is a complicated system involving a series of measurements which are then combined to produce three numbers (in the range [0, 255]) for any given tree. Thus each tree can be thought of as occupying a point in a 3-dimensional space. Because of the nature of the process, measurements for a large sample of trees are likely to be spread fairly uniformly throughout the whole of the available space. However Dr Larch is convinced that there are relationships to be found between close neighbours in this space. To test this hypothesis, he needs a histogram of the numbers of trees that have closest neighbours that lie within certain distance ranges.

    Write a program that will read in the parameters of up to 5000 trees and determine how many of them have closest neighbours that are less than 1 unit away, how many with closest neighbours 1 or more but less than 2 units away, and so on up to those with closest neighbours 9 or more but less than 10 units away. Thus iftex2html_wrap_inline26 is the distance between the i'th point and its nearest neighbour(s) and tex2html_wrap_inline28 , with j and k integers and k = j+1, then this point (tree) will contribute 1 to the j'th bin in the histogram (counting from zero). For example, if there were only two points 1.414 units apart, then the histogram would be 0, 2, 0, 0, 0, 0, 0, 0, 0, 0.

    Input and Output

    Input will consist of a series of lines, each line consisting of 3 numbers in the range [0, 255]. The file will be terminated by a line consisting of three zeroes.

    Output will consist of a single line containing the 10 numbers representing the desired counts, each number right justified in a field of width 4.

    Sample input

    10 10 0
    10 10 0
    10 10 1
    10 10 3
    10 10 6
    10 10 10
    10 10 15
    10 10 21
    10 10 28
    10 10 36
    10 10 45
    0 0 0

    Sample output

       2   1   1   1   1   1   1   1   1   1



    #include<stdio.h>
    #include<string.h>
    #include<math.h>
    #define MAXN 195075
    int path[5002][4];
    
    int deal(int x, int y, int z, int a, int b, int c)
    {
        double _x = (double)x, _y = (double)y, _z = (double)z;
        double _a = (double)a, _b = (double)b, _c = (double)c;
        double dis;
        dis = sqrt((_x - _a)*(_x - _a) + (_y - _b)*(_y - _b) + (_z - _c)*(_z - _c));
        return (int)floor(dis);
    }
    
    int main()
    {
        int i, j, n, x, y, z, count = 0, closedge[12], k, m;
        memset(path, 0, sizeof(path));
        memset(closedge, 0, sizeof(closedge));
        while(scanf("%d%d%d", &x, &y, &z) != EOF)
        {
            if(!x && !y && !z)
            {
                for(i=0; i<count; ++i)
                {
                    k = MAXN;
                    for(j=0; j<count; ++j)
                    {
                        if(i != j)
                        {
                            n = deal(path[i][0], path[i][1], path[i][2], path[j][0], path[j][1], path[j][2]);
                            if(n < k) k = n;
                        }
                    }
                    if(k < 10) closedge[k]++;
                }
                for(i=0; i<10; ++i)
                printf("%4d", closedge[i]);
                printf("\n");
            }
            else
            {
                path[count][0] = x;
                path[count][1] = y;
                path[count++][2] = z;
            }
        }
        return 0;
    }

    解题报告:

    对于每棵树找出与它最近的那个树的距离,如果小于10(换成不大于实际距离的最大整数)则在统计该特定距离的区域标记加1, 最后是看这些树中两树距离为 0 - 9 的树各有多少棵, 简单的比较两数的大小的题

  • 相关阅读:
    POJ 1320 Street Numbers(佩尔方程)
    hdu 3292 No more tricks, Mr Nanguo
    佩尔方程
    hdu 4825 xor sum(字典树+位运算)
    Xor Sum 2(位运算)
    数串
    EJS
    JQuery性能优化
    常用正则
    JavaScript prototype继承中的问题
  • 原文地址:https://www.cnblogs.com/liaoguifa/p/2839932.html
Copyright © 2011-2022 走看看