zoukankan      html  css  js  c++  java
  • Uva 10790 How Many Points of Intersection?

    How Many Points of Intersection?

    We have two rows. There are a dots on the top row and b dots on the bottom row. We draw line segments connecting every dot on the top row with every dot on the bottom row. The dots are arranged in such a way that the number of internal intersections among the line segments is maximized. To achieve this goal we must not allow more than two line segments to intersect in a point. The intersection points on the top row and the bottom are not included in our count; we can allow more than two line segments to intersect on those two rows. Given the value of a and b, your task is to compute P(a, b), the number of intersections in between the two rows. For example, in the following figure a = 2 and b = 3. This figure illustrates that P(2, 3) = 3.

    \epsfbox{p10790.eps}

    Input

    Each line in the input will contain two positive integers a ( 0 < a$ \le$20000) and b ( 0 < b$ \le$20000). Input is terminated by a line where both a and b are zero. This case should not be processed. You will need to process at most 1200 sets of inputs.

    Output

    For each line of input, print in a line the serial of output followed by the value of P(a, b). Look at the output for sample input for details. You can assume that the output for the test cases will fit in 64-bitsigned integers.

    Sample Input

    2 2
    2 3
    3 3
    0 0
    

    Sample Output

    Case 1: 1
    Case 2: 3
    Case 3: 9
    

    Problem setter: Md. Bahlul Haider Special Thanks: Shahriar Manzoor

    Miguel Revilla 2004-12-10
     
    #include<stdio.h>
    #include<string.h>
    
    int main()
    {
        int cnt = 0;
        long long sum, n, m;
        while(scanf("%lld%lld", &n, &m) != EOF)
        {
            if(n == 0 && m == 0) break;
            sum = m*(m-1)*n*(n-1)/4;
            printf("Case %d: %lld\n", ++cnt, sum);
        }
        return 0;
    }

    解题思路:

  • 相关阅读:
    Hibernate实现limit查询报错 :unexpected token: limit near line 1, column 33 [from pojo.Product p order by id limit ?,? ]
    slot_filling
    Perplexity(困惑度)
    图网络
    textrank
    copynet
    PGN
    beam-search的改进
    项目实战:如何构建知识图谱
    实体关系三元组抽取
  • 原文地址:https://www.cnblogs.com/liaoguifa/p/2943371.html
Copyright © 2011-2022 走看看