zoukankan      html  css  js  c++  java
  • Uva 10879 Code Refactoring

    Problem B
    Code Refactoring
    Time Limit: 2 seconds

     

    "Harry, my dream is a code waiting to be
    broken. Break the code, solve the crime."

    Agent Cooper

     

    Several algorithms in modern cryptography are based on the fact that factoring large numbers is difficult. Alicia and Bobby know this, so they have decided to design their own encryption scheme based on factoring. Their algorithm depends on a secret code, K, that Alicia sends to Bobby before sending him an encrypted message. After listening carefully to Alicia's description, Yvette says, "But if I can intercept K and factor it into two positive integers, A and B, I would break your encryption scheme! And the K values you use are at most 10,000,000. Hey, this is so easy; I can even factor it twice, into two different pairs of integers!"

    Input
    The first line of input gives the number of cases, N (at most 25000). N test cases follow. Each one contains the code, K, on a line by itself.

    Output
    For each test case, output one line containing "Case #xK = A * B = C * D", where ABC and D are different positive integers larger than 1. A solution will always exist.

     

    Sample Input Sample Output
    3
    120
    210
    10000000
    
    Case #1: 120 = 12 * 10 = 6 * 20
    Case #2: 210 = 7 * 30 = 70 * 3
    Case #3: 10000000 = 10 * 1000000 = 100 * 100000
    

     


    Problemsetter: Igor Naverniouk

     

    #include<stdio.h>
    #include<string.h>
    #define MAXN 10000
    int prime[MAXN];
    int flag[MAXN];
    
    is_prime()
    {
        int i, j, n = 0;
        memset(flag, 0, sizeof(flag));
        for(i=2; i<MAXN; ++i)
        {
            if(!flag[i])
            {
                prime[n++] = i;
                flag[i] = 1;
                for(j=i+i; j<MAXN; j+=i)
                flag[j] = 1;
            }
        }
        
        return n;
    }
    
    int main()
    {
        int term, track, i, T, cnt = 0, n, temp, a, b, c, d;
        term = is_prime();
        scanf("%d", &T);
        while(++cnt <= T)
        {
            scanf("%d", &n);
            temp = n;
    
            for(track=i=0; n != 1 && n != 0 && i<term; ++i)
            {
                while(n%prime[i] == 0) 
                {
                    flag[track++] = prime[i];
                    n /= prime[i];
                }
            }
            if(n != 1) flag[track++] = n;
            
            a = temp/flag[0], b = temp/a;
            for(c=d=1,i=0; i<track; ++i)
            {
                c *= flag[i];
                if(c != a && c != b) break;
            }
                
            d = temp/c;
            printf("Case #%d: %d = %d * %d = %d * %d\n", cnt, temp, a, b, c, d);
        }
        
        return 0;
    }

    解题思路:

    这题比较简单,因为是特判题(Special judge)题目的要求很宽,题目的背景设得太渣了,什么  After listening carefully to Alicia's description 然后就没了逻辑性了,还是直接看Sample好,

    思路跟上面几题一样,还是找因子,然后累乘找到能整除n的两个不同的数a, c ( a*c != n),然后按题目要求输出就行了

  • 相关阅读:
    第三章 系统总线
    人工神经网络及其应用
    专家系统
    遗传算法
    搜索算法策略
    js判断有无属性及新添属性
    vue 文件插件 Vetur 设置说明官网
    vue 获得当前无素并做相应处理
    VUE style 绑定
    vue入门基础知识点测试
  • 原文地址:https://www.cnblogs.com/liaoguifa/p/2952308.html
Copyright © 2011-2022 走看看