zoukankan      html  css  js  c++  java
  • HDU 1080 Human Gene Functions(最长公共子序列变形)

    Human Gene Functions

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 1065    Accepted Submission(s): 623

    Problem Description

    It is well known that a human gene can be considered as a sequence, consisting of four nucleotides, which are simply denoted by four letters, A, C, G, and T. Biologists have been interested in identifying human genes and determining their functions, because these can be used to diagnose human diseases and to design new drugs for them. 

    A human gene can be identified through a series of time-consuming biological experiments, often with the help of computer programs. Once a sequence of a gene is obtained, the next job is to determine its function. One of the methods for biologists to use in determining the function of a new gene sequence that they have just identified is to search a database with the new gene as a query. The database to be searched stores many gene sequences and their functions – many researchers have been submitting their genes and functions to the database and the database is freely accessible through the Internet. 

    A database search will return a list of gene sequences from the database that are similar to the query gene. Biologists assume that sequence similarity often implies functional similarity. So, the function of the new gene might be one of the functions that the genes from the list have. To exactly determine which one is the right one another series of biological experiments will be needed. 

    Your job is to make a program that compares two genes and determines their similarity as explained below. Your program may be used as a part of the database search if you can provide an efficient one. 

    Given two genes AGTGATG and GTTAG, how similar are they? One of the methods to measure the similarity of two genes is called alignment. In an alignment, spaces are inserted, if necessary, in appropriate positions of the genes to make them equally long and score the resulting genes according to a scoring matrix. 

    For example, one space is inserted into AGTGATG to result in AGTGAT-G, and three spaces are inserted into GTTAG to result in –GT--TAG. A space is denoted by a minus sign (-). The two genes are now of equal length. These two strings are aligned: 

    AGTGAT-G 
    -GT--TAG 

    In this alignment, there are four matches, namely, G in the second position, T in the third, T in the sixth, and G in the eighth. Each pair of aligned characters is assigned a score according to the following scoring matrix.


    * denotes that a space-space match is not allowed. The score of the alignment above is (-3)+5+5+(-2)+(-3)+5+(-3)+5=9. 
    Of course, many other alignments are possible. One is shown below (a different number of spaces are inserted into different positions): 
    AGTGATG 
    -GTTA-G 
    This alignment gives a score of (-3)+5+5+(-2)+5+(-1) +5=14. So, this one is better than the previous one. As a matter of fact, this one is optimal since no other alignment can have a higher score. So, it is said that the similarity of the two genes is 14.

    Input

    The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case consists of two lines: each line contains an integer, the length of a gene, followed by a gene sequence. The length of each gene sequence is at least one and does not exceed 100. 

    Output

    The output should print the similarity of each test case, one per line. 

    Sample Input

    2

    7 AGTGATG

    5 GTTAG

    7 AGCTATT

    9 AGCTTTAAA

    Sample Output

    14

    21

    Source

    Asia 2001, Taejon (South Korea)

    Statistic | Submit | Discuss | Note

    解题报告:题意:就是求基因的相似度,这个题是最长公共子序列的变形,状态方程:

    dp[i][j]=Max(dp[i-1][j-1]+map[s1[i-1]][s2[j-1]],dp[i-1][j]+map[s1[i-1]][4],dp[i][j-1]+map[4][s2[j-1]]);

    代码如下:

    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <cstdlib>
    using namespace std;
    const int N = 110;
    int s1[N],s2[N],dp[N][N];
    //存储他们的“权值”
    int map[5][5]=
    {
    5,-1,-2,-1,-3,
    -1,5,-3,-2,-4,
    -2,-3,5,-2,-2,
    -1,-2,-2,5,-1,
    -3,-4,-2,-1,0
    };
    int Search(char c)
    {
    if(c=='A')
    {
    return 0;
    }
    else if(c=='C')
    {
    return 1;
    }
    else if(c=='G')
    {
    return 2;
    }
    else if(c=='T')
    {
    return 3;
    }
    }
    int Max(int a,int b,int c)
    {
    int max;
    max=a>b?a:b;
    max=max>c?max:c;
    return max;
    }
    int main()
    {
    int t,len1,len2,i,j;
    scanf("%d",&t);
    while(t--)
    {
    char str1[N],str2[N];
    memset(dp,0,sizeof(dp));
    memset(s1,0,sizeof(s1));
    memset(s2,0,sizeof(s2));
    scanf("%d%s",&len1,str1);
    scanf("%d%s",&len2,str2);
    for(i=0;i<len1;i++)//
    {
    s1[i]=Search(str1[i]);
    }
    for(i=0;i<len2;i++)
    {
    s2[i]=Search(str2[i]);
    }
    dp[0][0]=0;
    for(i=1;i<=len1;i++)//对边界的处理就是和”-”组合时
    {
    dp[i][0]=dp[i-1][0]+map[4][s1[i-1]];
    }
    for(i=1;i<=len2;i++)//对边界的处理
    {
    dp[0][i]=dp[0][i-1]+map[s2[i-1]][4];
    }
    for(i=1;i<=len1;i++)
    {
    for(j=1;j<=len2;j++)
    {
    dp[i][j]=Max(dp[i-1][j-1]+map[s1[i-1]][s2[j-1]],dp[i-1][j]+map[s1[i-1]][4],dp[i][j-1]+map[4][s2[j-1]]);
    }
    }
    printf("%d\n",dp[len1][len2]);
    }
    return 0;
    }



  • 相关阅读:
    MFC框架程序实现十一
    MFC框架程序实现八
    MFC框架程序实现十二
    在Visual C++中如何利用UDL文件来建立ADO连接
    OnePage收集 HA
    微博跳转的url HA
    淘宝iosapp调用规范 HA
    Excel操作相关 HA
    C#GDI+编程基础 HA
    html5deoms HA
  • 原文地址:https://www.cnblogs.com/lidaojian/p/2270893.html
Copyright © 2011-2022 走看看