zoukankan      html  css  js  c++  java
  • HDU 4165 Pills(动态规划)

    Pills

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 42    Accepted Submission(s): 36

    Problem Description

    Aunt Lizzie takes half a pill of a certain medicine every day. She starts with a bottle that contains N pills.

    On the first day, she removes a random pill, breaks it in two halves, takes one half and puts the other half back into the bottle.

    On subsequent days, she removes a random piece (which can be either a whole pill or half a pill) from the bottle. If it is half a pill, she takes it. If it is a whole pill, she takes one half and puts the other half back into the bottle.

    In how many ways can she empty the bottle? We represent the sequence of pills removed from the bottle in the course of 2N days as a string, where the i-th character is W if a whole pill was chosen on the i-th day, and H if a half pill was chosen (0 <= i < 2N). How many different valid strings are there that empty the bottle?

    Input

    The input will contain data for at most 1000 problem instances. For each problem instance there will be one line of input: a positive integer N <= 30, the number of pills initially in the bottle. End of input will be indicated by 0.

    Output

    For each problem instance, the output will be a single number, displayed at the beginning of a new line. It will be the number of different ways the bottle can be emptied.

    Sample Input

    6

    1

    4

    2

    3

    30

    0

    Sample Output

    132

    1

    14

    2

    5

    3814986502092304

    Source

    The 2011 Rocky Mountain Regional Contest

    Recommend

    lcy

    解题报告:做这道题的时候以为是递归呢!结果推了一下推不出来,今天杭电比赛不知道,来的比较晚,看队友做出来了,就问了一下队友,其实这道题是一道动态规划的题目,每个状态都和前面的状态有关。为了好描述这道题我画了一张表,如下:就是把每一行加起来即为所求。

    代码如下:

    #include <iostream>
    #include <cstdio>
    #include <cstring>
    using namespace std;
    const int N = 32;
    __int64 dp[N][N];//这儿也得是64位
    void DP()
    {
    int i , j;
    memset(dp, 0, sizeof(dp));
    dp[0][0] = 1;//初始化
    for (i = 1; i <= 30; ++i)//初始化
    {
    dp[i][1] = 1;
    }
    for (i = 1; i <= 30; ++i)
    {
    for (j = 2; j <= i; j ++)
    {
    dp[i][j] = dp[i - 1][j] + dp[i][j - 1];//状态方程
    }
    }
    }
    int main()
    {
    int n, i;
    __int64 ans;
    DP();
    while (scanf("%d", &n) != EOF &&n)
    {
    ans = 0;
    for (i = 1; i <= n; ++i)
    {
    ans += dp[n][i];
    }
    printf("%I64d\n", ans);
    }
    return 0;
    }



  • 相关阅读:
    Xshell学习第九课:数组与字符串
    Xshell学习第八课:函数
    Xshell学习第七课:sed语句
    Xshell学习第六课:read与for语句循环
    Xshell学习第五课:if判断语句
    Xshell学习第四课:grep与正则表达式
    Xshell学习第三课:编程原理
    Xshell学习第二课:重定向和管道符
    iOS中坐标转换
    iOS工作笔记(十五)
  • 原文地址:https://www.cnblogs.com/lidaojian/p/2378561.html
Copyright © 2011-2022 走看看