zoukankan      html  css  js  c++  java
  • POJ 2253 Frogger(最短路径Dijkstra的变形)

    Frogger

    Time Limit: 1000MS

     

    Memory Limit: 65536K

    Total Submissions: 15491

     

    Accepted: 5124

    Description

    Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping. 
    Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps. 
    To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence. 
    The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones. 

    You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone. 

    Input

    The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.

    Output

    For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

    Sample Input

    2

    0 0

    3 4

     

    3

    17 4

    19 4

    18 5

     

    0

    Sample Output

    Scenario #1

    Frog Distance = 5.000

     

    Scenario #2

    Frog Distance = 1.414

    Source

    Ulm Local 1997

     解题报告:给出两只青蛙的起始位置,找出青蛙跳到第2块的最短距离。这个题就是最短路径的变形,就是在求最短路径时更新最短路信息的时候不一样,

    即在每条路径里最短的最长的那条分路径,再在里面选择最短的那条。

    代码如下:

    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <cmath>
    using namespace std;
    const int N = 210;
    const double INF = 99999999;
    double map[N][N], dis[N];
    int visit[N], n;
    struct node
    {
    double x, y;
    }a[N];
    double Dis(int i, int j)//计算两点间的距离
    {
    return sqrt((a[i].x - a[j].x) * (a[i].x - a[j].x) + (a[i].y - a[j].y) * (a[i].y - a[j].y));
    }
    double Max(double c, double d)
    {
    return c > d ? c : d;
    }
    double Min(double c, double d)
    {
    return c < d ? c : d;
    }
    void Dijkstra()
    {
    int i, j, p;
    double min, max;
    for (i = 1; i <= n; ++i)//初始化
    {
    dis[i] = map[1][i];
    }
    visit[1] = 1;
    for (i = 2; i <= n; ++i)
    {
    min = INF;
    for (j = 1; j <= n; ++j)
    {
    if (!visit[j] && min > dis[j])
    {
    min = dis[j];
    p = j;
    }
    }
    visit[p] = 1;
    for (j = 1; j <= n; ++j)//就是这儿和Dijkstra算法不同,
    {
    max = Max(dis[p], map[p][j]);//每条路径里最短的最长的那条分路径
    dis[j] = Min(dis[j], max);
    }
    }
    }
    int main()
    {
    int i, j, count = 1;
    while (scanf("%d", &n) != EOF && n)
    {
    memset(map, 0, sizeof(map));
    memset(visit, 0, sizeof(visit));
    memset(dis, 0, sizeof(dis));
    for(i = 1; i <= n; ++i)
    {
    scanf("%lf%lf", &a[i].x, &a[i].y);
    }
    for (i = 1; i <= n; ++i)
    {
    for (j = 1; j <= i - 1; ++j)
    {
    map[i][j] = map[j][i] = Dis(i, j);
    }
    }
    Dijkstra();
    printf("Scenario #%d\n", count++);
    printf("Frog Distance = %.3lf\n\n", dis[2]);
    }
    }



  • 相关阅读:
    C语言I博客作业03
    C语言I博客作业02
    macwingIDE python3.5 配置
    JAVA必会算法插入排序
    java匿名内部类的另一个用途
    JAVA必会算法选择排序
    Mac elasticsearch 5.2.2 单机双节点配置
    JAVA必会算法二分查找法
    AOP 事物连接,记忆连接数据库,连接池
    线程的意义与一些常见面试问题
  • 原文地址:https://www.cnblogs.com/lidaojian/p/2382581.html
Copyright © 2011-2022 走看看