zoukankan      html  css  js  c++  java
  • SDUT 2370 || POJ 2940 Wine Trading in Gergovia(简单贪心)

    Wine Trading in Gergovia

    Time Limit: 1000MS

     

    Memory Limit: 65536K

    Total Submissions: 2653

     

    Accepted: 1183

    Description

    As you may know from the comic “Asterix and the Chieftain’s Shield”, Gergovia consists of one street, and every inhabitant of the city is a wine salesman. You wonder how this economy works? Simple enough: everyone buys wine from other inhabitants of the city. Every day each inhabitant decides how much wine he wants to buy or sell. Interestingly, demand and supply is always the same, so that each inhabitant gets what he wants.

    There is one problem, however: Transporting wine from one house to another results in work. Since all wines are equally good, the inhabitants of Gergovia don’t care which persons they are doing trade with, they are only interested in selling or buying a specific amount of wine. They are clever enough to figure out a way of trading so that the overall amount of work needed for transports is minimized.

    In this problem you are asked to reconstruct the trading during one day in Gergovia. For simplicity we will assume that the houses are built along a straight line with equal distance between adjacent houses. Transporting one bottle of wine from one house to an adjacent house results in one unit of work.

    Input

    The input consists of several test cases.

    Each test case starts with the number of inhabitants n (2 ≤ n ≤ 100000). The following line contains n integers ai (−1000 ≤ ai ≤ 1000). If ai ≥ 0, it means that the inhabitant living in the ith house wants to buy ai bottles of wine, otherwise if ai < 0, he wants to sell −ai bottles of wine. You may assume that the numbers ai sum up to 0.

    The last test case is followed by a line containing 0.

    Output

    For each test case print the minimum amount of work units needed so that every inhabitant has his demand fulfilled. You may assume that this number fits into a signed 64-bit integer (in C/C++ you can use the data type “long long” or “__int64”, in JAVA the data type “long”).

    Sample Input

    5

    5 -4 1 -3 1

    6

    -1000 -1000 -1000 1000 1000 1000

    0

    Sample Output

    9

    9000

    Source

    Ulm Local 2006

     解题报告:这道题就是求最小工作量,就近原则,一户一户的依次统计!就是贪心,下午的时候是队友做出来的,

    代码如下:

    #include <iostream>
    #include <cstdio>
    using namespace std;
    int main()
    {
    int n, i;
    __int64 sum, ans, a;
    while (scanf("%d", &n) != EOF && n)
    {
    ans = 0;
    sum = 0;
    for (i = 0; i < n; ++i)
    {
    scanf("%I64d", &a);
    sum += a;
    if (sum > 0)
    {
    ans += sum;
    }
    else
    {
    ans -= sum;
    }
    }
    printf("%I64d\n", ans);
    }
    return 0;
    }



  • 相关阅读:
    接口中可以定义内部类举例
    eclipse中项目maven update无法停止解决方法
    tomcat failed to start / could not publish server configuration解决
    导入项目时jsp带红叉,或者实现类提示需要override接口的问题
    常见异常与总结——一句话的描述
    Maven导入shiro的依赖后,欢迎页面404、shiro-features异常的解决方案:
    eclipse解决maven项目右键run as没有run on server的问题:
    SpringCloud搭建教程
    异常:java.lang.IllegalArgumentException: Could not resolve placeholder 'xxx' in value "${xxx}"
    SQL题1——查询所有购入商品为两种或两种以上的购物人记录
  • 原文地址:https://www.cnblogs.com/lidaojian/p/2416306.html
Copyright © 2011-2022 走看看