zoukankan      html  css  js  c++  java
  • POJ 1837 Balance(01背包应用)

    Balance

    Time Limit: 1000MS

     

    Memory Limit: 30000K

    Total Submissions: 6667

     

    Accepted: 4013

    Description

    Gigel has a strange "balance" and he wants to poise it. Actually, the device is different from any other ordinary balance. 
    It orders two arms of negligible weight and each arm's length is 15. Some hooks are attached to these arms and Gigel wants to hang up some weights from his collection of G weights (1 <= G <= 20) knowing that these weights have distinct values in the range 1..25. Gigel may droop any weight of any hook but he is forced to use all the weights. 
    Finally, Gigel managed to balance the device using the experience he gained at the National Olympiad in Informatics. Now he would like to know in how many ways the device can be balanced. 

    Knowing the repartition of the hooks and the set of the weights write a program that calculates the number of possibilities to balance the device. 
    It is guaranteed that will exist at least one solution for each test case at the evaluation. 

    Input

    The input has the following structure: 
    • the first line contains the number C (2 <= C <= 20) and the number G (2 <= G <= 20); 
    • the next line contains C integer numbers (these numbers are also distinct and sorted in ascending order) in the range -15..15 representing the repartition of the hooks; each number represents the position relative to the center of the balance on the X axis (when no weights are attached the device is balanced and lined up to the X axis; the absolute value of the distances represents the distance between the hook and the balance center and the sign of the numbers determines the arm of the balance to which the hook is attached: '-' for the left arm and '+' for the right arm); 
    • on the next line there are G natural, distinct and sorted in ascending order numbers in the range 1..25 representing the weights' values. 

    Output

    The output contains the number M representing the number of possibilities to poise the balance.

    Sample Input

    2 4   
    -2 3 
    3 4 5 8

    Sample Output

    2

    Source

    Romania OI 2002

     解题报告:这道题题意就是给我们一个杠杆,给我们c个可以挂东西的位置,再给我们g个物品的质量,让我们求最多有多少种方法能使天平保持平衡(以中点为支点),因为杠杆所能加载的最大重量是15 * 20 * 25 = 7500;可以转化为01背包问题,力 = 力距 * 距离;

    代码如下:

    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <cstdlib>
    using namespace std;
    const int MAX = 15010;
    int w[25], l[25], dp[25][MAX];
    int main()
    {
        int c, g, i, j, v;
        while (scanf("%d%d", &c, &g) != EOF)
        {
            for (i = 1; i <= c; ++i)
            {
                scanf("%d", &l[i]);
            }
            for (i = 1; i <= g; ++i)
            {
                scanf("%d", &w[i]);
            }
            dp[0][7500] = 1;
            for (i = 1; i <= g; ++i)
            {
                for (j = 1; j <= c; ++j)
                {
                    for (v = 0; v < MAX; ++v)
                    {
                        if (dp[i - 1][v] != 0)
                        {
                            dp[i][v + w[i] * l[j]] += dp[i - 1][v];
                        }
                    }
                }
            }
            printf("%d\n", dp[g][7500]);
        }
        return 0;
    }
  • 相关阅读:
    利用中转输出表制作HijackDll
    webshell查杀
    说说无线路由器后门的那些事儿(1)-D-Link篇
    htpwdScan — 一个简单的HTTP暴力破解、撞库攻击脚本
    OD消息断点
    Burp Suite详细使用教程-Intruder模块详3
    burp intruder模块详解
    谈谈神的能力
    语法入门基本概念
    多项式
  • 原文地址:https://www.cnblogs.com/lidaojian/p/2500518.html
Copyright © 2011-2022 走看看