zoukankan      html  css  js  c++  java
  • POJ 1789:Truck History

    Truck History
    Time Limit: 2000MS   Memory Limit: 65536K
    Total Submissions: 21376   Accepted: 8311

    Description

    Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for bricks. The company has its own code describing each type of a truck. The code is simply a string of exactly seven lowercase letters (each letter on each position has a very special meaning but that is unimportant for this task). At the beginning of company's history, just a single truck type was used but later other types were derived from it, then from the new types another types were derived, and so on. 

    Today, ACM is rich enough to pay historians to study its history. One thing historians tried to find out is so called derivation plan -- i.e. how the truck types were derived. They defined the distance of truck types as the number of positions with different letters in truck type codes. They also assumed that each truck type was derived from exactly one other truck type (except for the first truck type which was not derived from any other type). The quality of a derivation plan was then defined as 
    1/Σ(to,td)d(to,td)

    where the sum goes over all pairs of types in the derivation plan such that to is the original type and td the type derived from it and d(to,td) is the distance of the types. 
    Since historians failed, you are to write a program to help them. Given the codes of truck types, your program should find the highest possible quality of a derivation plan. 

    Input

    The input consists of several test cases. Each test case begins with a line containing the number of truck types, N, 2 <= N <= 2 000. Each of the following N lines of input contains one truck type code (a string of seven lowercase letters). You may assume that the codes uniquely describe the trucks, i.e., no two of these N lines are the same. The input is terminated with zero at the place of number of truck types.

    Output

    For each test case, your program should output the text "The highest possible quality is 1/Q.", where 1/Q is the quality of the best derivation plan.

    Sample Input

    4
    aaaaaaa
    baaaaaa
    abaaaaa
    aabaaaa
    0
    

    Sample Output

    The highest possible quality is 1/3.

    题目给了N个字符串,每个字符串有7个字符。每个字符串之间都有所谓的“距离”:即不相等的数量。问这些字符串之间一共的距离之和最小是多少。

    计算每对字符串之间的距离,之后求其最小生成树。

    代码:

    #include <iostream>
    #include <algorithm>
    #include <cmath>
    #include <vector>
    #include <string>
    #include <cstring>
    #pragma warning(disable:4996)
    using namespace std;
    
    int num;
    char truck[2005][10];
    int map[2005][2005];
    int stack[2005];
    int minidis[2005];
    
    int dis(int x,int y)
    {
    	int i,result=0;
    	for(i=0;i<7;i++)
    	{
    		if(truck[x][i]!=truck[y][i])
    		{
    			result++;
    		}
    	}
    	return result;
    }
    
    int prim()
    {
    	int i,j,s,result;
    
    	memset(stack,0,sizeof(stack));
    	for(i=1;i<=num;i++)
    	{
    		minidis[i]=15;
    	}
    
    	stack[1]=1;
    	minidis[1]=0;
    	s=1;
    	result=0;
    	for(i=1;i<=num-1;i++)
    	{
    		int min_all=15;
    		int min_temp=0;
    		for(j=2;j<=num;j++)
    		{
    			if(stack[j]==0&&minidis[j]>map[s][j])
    			{
    				minidis[j]=map[s][j];
    			}
    			if(stack[j]==0&&minidis[j]<min_all)
    			{
    				min_temp=j;
    				min_all=minidis[j];
    			}
    		}
    		s=min_temp;
    		stack[s]=1;
    		result += min_all;
    	}
    	return result;
    }
    
    int main()
    {
    	int i,j;
    	while(cin>>num)
    	{
    		if(num==0)
    			break;
    		for(i=1;i<=num;i++)
    		{
    			scanf("%s",truck[i]);
    		}
    		for(i=1;i<=num;i++)
    		{
    			for(j=i+1;j<=num;j++)
    			{
    				map[i][j]=map[j][i]=dis(i,j);
    			}
    		}
    		cout<<"The highest possible quality is 1/"<<prim()<<"."<<endl;
    	}
    
    	return 0;
    }
    


    版权声明:本文为博主原创文章,未经博主允许不得转载。

  • 相关阅读:
    windows 挂载windows 共享盘为本地磁盘
    模块
    message 匹配不上grok正则 也会写入到elasticsearch
    【Java】No enclosing instance of type XXX is accessible. Must qualify the allocation with an enclosing instance of type XXX(e.g. x.new A() where x is an instance of XXX).的解决办法
    【Ubuntu】常用软件及其下载地址
    【Java】内存分析
    【Java】利用二维数组进行排版
    【Java】一维数组
    【趣题】用for循环输出菱形
    【趣题】穷举法解决百钱买百鸡
  • 原文地址:https://www.cnblogs.com/lightspeedsmallson/p/4785784.html
Copyright © 2011-2022 走看看