zoukankan      html  css  js  c++  java
  • POJ 3627:Bookshelf


    Bookshelf
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 7758   Accepted: 3906

    Description

    Farmer John recently bought a bookshelf for cow library, but the shelf is getting filled up quite quickly, and now the only available space is at the top.

    Each of the N cows (1 ≤ N ≤ 20,000) has some height of Hi (1 ≤ Hi ≤ 10,000) and a total height summed across all N cows of S. The bookshelf has a height of B (1 ≤ B ≤ S < 2,000,000,007).

    To reach the top of the bookshelf taller than the tallest cow, one or more of the cows can stand on top of each other in a stack, so that their total height is the sum of each of their individual heights. This total height must be no less than the height of the bookshelf. Since more cows than necessary in the stack can be dangerous, your job is to find the set of cows that produces a stack of the smallest number of cows possible such that the stack can reach the bookshelf.

    Input

    * Line 1: Two space-separated integers: N and B
    * Lines 2..N+1: Line i+1 contains a single integer: Hi

    Output

    * Line 1: A single integer representing the size of the smallest set of cows that can reach the bookshelf.

    Sample Input

    6 40
    6
    18
    11
    13
    19
    11
    

    Sample Output

    3

    大水题,给出一个数的序列,求最小的数量m,使这序列中m个数的和大于等于给定的数。

    从大到小排个序。什么时候大于等于给定数值了,就输出即可。

    代码:

    #include <iostream>
    #include <algorithm>
    #include <cmath>
    #include <vector>
    using namespace std;
    
    bool cmp(int a,int b)
    {
    	return a>b;
    }
    
    int main()
    {
    	int N,B,i;
    	int height[20005];
    	cin>>N>>B;
    
    	for(i=0;i<N;i++)
    	{
    		cin>>height[i];
    	}
    	sort(height,height+N,cmp);
    
    	int ans=0;
    	for(i=0;i<N;i++)
    	{
    		ans += height[i];
    		if(ans>=B)
    		{
    			cout<<i+1<<endl;
    			return 0;
    		}
    	}
    	return 0;
    }
    



    版权声明:本文为博主原创文章,未经博主允许不得转载。

  • 相关阅读:
    Spring
    JavaWeb
    JDBC
    MYSQL
    IDEA个人常用快捷键
    Web前端-JAVASCRIPT
    Web前端-HTML
    注解与反射
    多线程
    区块链 ATS多策略量化机器人简介
  • 原文地址:https://www.cnblogs.com/lightspeedsmallson/p/4785840.html
Copyright © 2011-2022 走看看