zoukankan      html  css  js  c++  java
  • HDU 1003:Max Sum

    Max Sum

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 174588    Accepted Submission(s): 40639


    Problem Description
    Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
     

    Input
    The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
     

    Output
    For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
     

    Sample Input
    2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
     

    Sample Output
    Case 1: 14 1 4 Case 2: 7 1 6


    题意:给定一个序列,求其子序列的最大和,还有最大和的子序列的起始位置和结束位置。

    求和与end都没什么好说的。求start是亮点,一开始判断了很久,后来还是那个想法,对于序列或是字符串正着想想不出来就逆过来想,从左到右end容易求,那从右至左的话start就容易求了。

    代码:

    #include <iostream>
    #include <string>
    #include <cstring>
    #include <algorithm>
    #include <cmath>
    #pragma warning(disable:4996) 
    using namespace std;
    
    int value[100005];
    int dp[100005];
    
    int main()
    {
    	//freopen("input.txt","r",stdin);
    	//freopen("out.txt","w",stdout);
    
    	int Test,num,i,j,ans,start,end;
    	value[0]=0;
    
    	cin>>Test;
    	for(j=1;j<=Test;j++)
    	{
    		ans = -1005;
    		memset(dp,0,sizeof(dp));
    
    		cin>>num;
    		for(i=1;i<=num;i++)
    		{
    			cin>>value[i];
    			dp[i]=max(dp[i-1]+value[i],value[i]);
    			if(dp[i]>ans)
    			{
    				ans=dp[i];
    				end=i;
    			}
    		}
    		ans=-1005;
    		memset(dp,0,sizeof(dp));
    		for(i=num;i>=1;i--)
    		{
    			dp[i]=max(dp[i+1]+value[i],value[i]);
    			if(dp[i]>=ans)
    			{
    				ans=dp[i];
    				start=i;
    			}
    		}
    		cout<<"Case "<<j<<":"<<endl;
    		cout<<ans<<" "<<start<<" "<<end<<endl;
    
    		if(j!=Test)
    			cout<<endl;
    	}
    
    	return 0;
    }

    后来看discuss里其他人的思路,觉得从end开始往回倒,对每一个值都加起来,什么时候等于求出来的最大和了,什么时候就是start了,觉得这样做也很好。


    版权声明:本文为博主原创文章,未经博主允许不得转载。

  • 相关阅读:
    vue store获取值时 Computed property "activeTag" was assigned to but it has no setter.
    深拷贝实现方法以及问题
    mac 中git操作账号的保存与删除
    解决Ubuntu编译内核uImage出现问题“mkimage” command not found
    ubuntu修改主机名后无法解析主机
    多行宏定义中的注释问题
    uboot启动阶段修改启动参数方法及分析
    ubuntu nfs服务器配置
    mount/umount命令详解
    Ubuntu下vsftp安装和配置
  • 原文地址:https://www.cnblogs.com/lightspeedsmallson/p/4785842.html
Copyright © 2011-2022 走看看